nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   rh7.3 and nvidia (http://www.nvnews.net/vbulletin/showthread.php?t=99)

vcrispo 07-28-02 07:25 PM

rh7.3 and nvidia
 
I have an Asus motherboard A7N277 with the onboard nvidia graphics, audio, and NiC. I have been trying to get RH 7.3 loaded for about three weeks now with no success.

With all the different tries I performed. I add the necessary lines and changed "nv" to /etc/X11/XF86Config-4,
ran /sbin/insmod (no errors)
ran /sbin/modprobe (no errors)
I also have commented out and uncomment the GLCore and dri settings.

I also performed a clean install before each different setup I have listed..

I'm also running the latest XFree86 file.

From what I can tell there were no errors received on any of the installs except for when I started "startx".

1. I ran NVchooser.sh under kernel 2.4.28-3 and it told me to run NVIDIA_GLX-1.0-2960.i386.rpm and NVIDIA_kernel-1.0.2960rh73up.athlon.rpm. I followed the instructions From the NVidia Linux website. Received no errors during the installs.

When I ran startx I got the error
(II) Load Module : nvidia
"(WW) Couldn't open module NVidia".
(II) Unload Module Nvidia
(EE) Failed to load module NVidia, ( module doesn't exits)

2. Under 2.4.18-3 I have also used NVIDIA_kernel-1.0-2960.tar.gz and NVIDIA_GLX-1.0-2960.tar.gz. I followed the instructions given in the NVIDIA website for Linux. Again I got the errors listed ubove.

Under 2.4.28-3 I also ran the 2880 series kernel from NVidia.

3. I also updated to kernel 2.4.28-5 making sure the source code was there. I performed the three steps listed above and still received the same error.

Does anyone recognize this error and what may be causing it. None of the posting I have read have dealt with this error. Further the NVidia FAQ doesn't address this problem either.

I emailed NVidia but they haven't responded to my email.

I have tried a few (not all) installs testing a few of the generic drivers without succes. Does anyone know a generic driver that might work.

I didn't have any of these problems before I upgraded to the new motherboard and video etc...

Thanks,
Vin

Bern 07-28-02 07:38 PM

The driver your trying to install is for a nvidia graphics card, for a nforce intergrated mobo you need to install these drivers,
http://www.nvidia.com/view.asp?IO=linux_nforce_1.0-0236
Get the tarball version.

tandlj 07-28-02 11:55 PM

looking for 'NVchooser.sh'
 
Two posts (vcrispo in 'rh7.3 and nvidia' and Error404 in 'nVidia drivers + Red Hat Linux 7.3') mentioned a script called "NVchooser.sh".

Could someone please post it or tell me where to find it?

(I am suffering from RH7.3's lack of support for nForce as well...)


Thanks, Joseph

:D

Bern 07-29-02 12:06 AM

http://download.nvidia.com/XFree86_4...0/NVchooser.sh

Thunderbird 07-29-02 03:07 AM

That special nforce driver package only contains a sound and network driver. For video you need the normal nvidia drivers.

You get the following error:
(II) Load Module : nvidia
"(WW) Couldn't open module NVidia".
(II) Unload Module Nvidia
(EE) Failed to load module NVidia, ( module doesn't exits)

I think the nvidia GLX drivers aren't installed. It tries to load nvidia_drv.o (needs to be in /usr/X11R6/lib/modules/drivers), but it can't find it.

vcrispo 07-29-02 07:43 PM

Thunderbird, Thanks for the reply. But I have already made that check and "nvidia_drv.o" is in /usr/X11R6/lib/modules/drivers. I have deleted it and readded it manually from the tarball "just in case".

Any other suggestions would be appreciated.


Thanks
Vin

easypzy 07-30-02 03:08 AM

Error SIGSEGV caught!
 
I have the same problem and cannot get the drivers to load properly. When I run xf86cfg I get error messages when it tries to load the nvidia module.

It looks like this:

Loading /usr/...../drivers/nvidia_drv.o
Module nvidia..... compiled for 4.0.2, module version 1.0....
Nvidia XFree86 Driver 1.0-2960 ...
Error SIGSEGV caught!

All the other drivers are compiled for 4.2.0 and loads nicely.

What could be wrong?

Thunderbird 07-30-02 03:37 AM

easypzy if what you say is really true the drivers segfault for you. If really true that would be a serious driver bug.

easypzy 07-30-02 07:11 AM

SIGSEGV error caught
 
Well that is what the output says. Anyone else with the same error?

easypzy 07-31-02 08:35 AM

Solved the problem
 
I uninstalled the upgrade of the kernel 2.4.18-5 and now everything works fine. The Nvidia drivers installs perfectly.

I am now using kernel 2.4.18-3.

easypzy 07-31-02 08:36 AM

Forgot to say that I am using RH 7.3.

vcrispo 07-31-02 08:57 PM

easypzy - Glad to hear you got it working. I think I'm going to try an older video card. I don't know what else to try.

Vin


All times are GMT -5. The time now is 12:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.