nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   trouble installing 1.0-4349 drivers. (http://www.nvnews.net/vbulletin/showthread.php?t=9902)

mvp 04-09-03 09:10 AM

trouble installing 1.0-4349 drivers.
 
i am using debian woody, and have a Geforce2MX card.

first i tried running NVIDIA-Linux-x86-1.0-4349.run but it was unablt to find the kernel header, so i install the correct kernal header and it's still the same, i also tried running the program with -kernel-/usr/src/kernel-headers-2.2.20-idepci and its still the same.

i also tried unpacking the .run file and then install manualy, but then it says [gcc check] error 1.
i tried inserting IGNORE_CC_MISMATCH in the Makefile, but that dosen't help it just writes missing seperator.

i'm new to linux so any help would be appreciatet

mvp 04-09-03 09:18 AM

btw. the output of gcc -dumpversion is 2.95.4 and the output of cat /proc/version is gcc version 2.7.2.3

bwkaz 04-09-03 11:49 AM

That's your problem -- there's a compiler version mismatch.

What you need to do is recompile your kernel with your system compiler, boot to the new kernel, and then retry the nVidia drivers.

mvp 04-09-03 02:04 PM

thanks, i'll try that

blubb0r 04-13-03 05:43 AM

Help
how do i recompile my kernel? im a REALLY new to linux, and dont know how to do this.
got the same problem, the driver doesnt find my kernel header files.
thx for help

bwkaz 04-13-03 07:54 AM

If the problem is just that it doesn't find the headers, then you can fix the problem by installing your distro's kernel-source package.

If you're getting a "compiler version mismatch" message in your nvidia-installer.log file (which is in /var/log), and if you are using Debian, then yes, you should recompile your kernel, as the Debian default kernel (in Woody at least) was compiled with an extremely old version of gcc, that isn't even installed in Woody anymore.

If you're getting compiler mismatches and you don't use Debian, though, then look into /proc/version and gcc -dumpversion to see which is newer. You may be able to fix the problem by upgrading gcc, or installing it if it isn't. Post the contentst of /proc/version and the output of gcc -dumpversion, too.

blubb0r 04-13-03 01:13 PM

Well i installed a new kernel via apt-get, the 2.4.18-k7, and it was the same problem.
any ideas?
will try that with recompiling and pointing at the headers.
pointing at the headers didnt work with 2.2.20 as far as i remember, so lets try with the new.

bwkaz 04-13-03 04:48 PM

Well, I do believe I asked for the contents of /proc/version and the output of gcc -dumpversion, so if you want to provide that information, you'll get a bit better answer from me...

blubb0r 04-13-03 06:08 PM

um sorry... but i looked that stuff up, and it says 2.95.4 in both cases, so it cant be that mismatch.
pleese help

i want to play quake3 and ut2k3 ^^

well my problem is the kernel headers.
they arent found even if i point at them.

c4p3d_crus4d3r 04-13-03 06:30 PM

Post your installer log

blubb0r 04-13-03 06:36 PM

so should i make it with makefile again, or u mean the errormessages with sh NVIDIA-Linux.... ?

with that sh option, its always that he doesnt findt my kernel-headers.
i apt-gettet them for both my 2.2.20 kernel and my 2.4.18. do i have to make more that apt-get to install the headers?

otherwise, i would have to make it with make again to get the error messages.

sorry. im very new to linux

bwkaz 04-13-03 06:56 PM

Don't bother with make, try to get the installer working. Tarballs won't be provided outside the installer framework in the future anyway (which doesn't make much sense to me, but I don't decide this kind of stuff, so oh well), so it's worthless if you can only get them to work. ;)

The installer looks for your kernel headers in /lib/modules/$(uname -r)/build/include, then (if they're not in that directory) in /usr/src/linux/include. Make sure that /lib/modules/$(uname -r)/build is a symlink to the base of your kernel source tree, or make sure that /usr/src/linux is a symlink to the base of the source tree. I believe that Debian's "kernel-headers" package is just kernel-source for any other distro, and I'm pretty sure it installs in /usr/src/linux-<version>/include.


All times are GMT -5. The time now is 03:28 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.