nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   Mouse stuck on one screen with dual-head on GeForce 7600 GT/Xorg 7.3 (http://www.nvnews.net/vbulletin/showthread.php?t=99241)

cotcomsol 09-27-07 06:09 PM

Mouse stuck on one screen with dual-head on GeForce 7600 GT/Xorg 7.3
 
I just upgraded my system to Xorg 7.3 and a new GeForce 7600 GT dual DVI card. I'm trying to get Dual Head working properly in a dual-screen (non twinview) setup. So far it works flawlessly except when I move the mouse from the left screen (screen0) to the right (screen1) it refuses to come back. There is no problem crossing from left to right, but trying to go right to left it gets stuck at the edge of the screen and refuses to cross!

I've tried many variations of the screen layout, LeftOf, RightOf, absolute on both, etc. Nothing seem to work.... Any ideas? Here is my xorg.conf


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (root@jail-5) Fri Aug 17 01:36:06 UTC 2007

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0"
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/share/X11/rgb"
ModulePath "/usr/X11R6/lib/xorg/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/OTF"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "extmod"
Load "record"
Load "dbe"
Load "glx"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "ServerFlags"
Option "IgnoreABI" "true"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psm0"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"

#DisplaySize 400 300 # mm
### Comment all HorizSync and VertRefresh values to use DDC:
# HorizSync 30.0 - 83.0
# VertRefresh 55.0 - 75.0
Identifier "Monitor0"
VendorName "Unknown"
ModelName "AOC 203P"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "AOC 203P"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7600 GT"
BusID "PCI:7:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7600 GT"
BusID "PCI:7:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "ModeValidation" "NoDFPNativeResolutionCheck"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "ModeValidation" "NoDFPNativeResolutionCheck"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Chronos_ 09-28-07 01:51 PM

Re: Mouse stuck on one screen with dual-head on GeForce 7600 GT/Xorg 7.3
 
There seem to be an awful lot of input module failures on 7.3. Missing keys, cursors that either don't swap displays or won't swap back, LEDs not working, etcetera.

This has been reported by a mailing list regular with a similar issue here. There is also a PR here which references a fix for x11-drivers/xf86-input-mouse/work/xf86-input-mouse-1.2.2/src/mouse.c. Hopefully, this will be applied to the port ASAP. edwin@ has passed the PR on to the maintainer.

cotcomsol 09-28-07 03:22 PM

Re: Mouse stuck on one screen with dual-head on GeForce 7600 GT/Xorg 7.3
 
Ah! Thank you! I manually patched my box using the info in the PR and it works perfectly now!

Brock


All times are GMT -5. The time now is 10:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.