nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   KT400 workaround (http://www.nvnews.net/vbulletin/showthread.php?t=9927)

Andy Mecham 04-09-03 07:28 PM

KT400 workaround
 
From ftp://download.nvidia.com/XFree86/Li...a-1.0-4349.txt -

o Starting X with AGP 8x video cards on systems with KT400 AGP
chipsets cause system hangs.

Solution: this problem can be worked around by disabling AGP
(Option "NvAGP" "0") in your XF86Config file.

Alternatively, you may be able to enable AGP 8x on your KT400 based
system by overriding the default NVreg_EnableAGPSBA registry key.
To do this you can either:

- set the value on the modprobe command line; for example:
modprobe nvidia NVreg_EnableAGPSBA=1

- add an options line to your module configuration file,
usually /etc/modules.conf; for example:
options nvidia NVreg_EnableAGPSBA=1

and use NVIDIA's AGP (Option "NvAGP" "1" in the Screen section
of your XF86Config file).

Let me know if this works.

--andy

Vwracer69 04-09-03 11:56 PM

KT400 workaround
 
ok, as far as i can tell it worked for me. Since im new to linux i did what u said and redhat 9 booted up sweat! I also got a dif in glxgears. I went from about 3000fps to 5000+ fps. Is there anyway to make sure this fix is working properly, or if i actualy enabled what u segested?

Thnx!:angel:

Dibbler 04-10-03 10:24 AM

KT400
 
Well, options nvidia NVreg_EnableAGPSBA=1 worked fine for me also, but however I can not have NVreg_EnableAGPFW=1 or it disables SBA?

However having said that, even tho it reports the following:-

Status: Enabled
Driver: NVIDIA
AGP Rate: 8x
Fast Writes: Disabled
SBA: Enabled

Performance has not increased one iota, a tad disapointing to only get 2200fps in glxgears in default window.

Any ideas Andy?

bwkaz 04-10-03 11:55 AM

Are you putting FW and SBA on different "options" lines in modules.conf? They have to be on the same line, or the second one will override the first.

Dibbler 04-10-03 12:18 PM

That was it, but unfortunately it is unstable. Thanks for the tip tho!!

Miss Netzen 04-10-03 01:34 PM

Works also on my system thx Andy. But why it is a workaround? Witch effects comes up with this option?

Now NWN runs very fine with linux (more fps than in Win**** ;)) *grin*

Dibbler 04-10-03 03:15 PM

Side band addressing (SBA) enables AGP to use 8 extra (Side band) address lines in addition to the 32 main ones to transmit requests for data, which should further improve AGP performance.

Sadly this has not been the case here, in fact I see absolutely no increase in performace whatsoever, over and above "NvAGP" "0", i.e disabling AGP altogether. If anybody has any ideas as to how I can improve the situation I'd be grateful.


For reference I have the following hardware:-

ASUS A7V8X Motherboard
Geforce 4 MX 440 64 GPU

cat /driver/nvidia/agp/status

Status: Enabled
Driver: NVIDIA
AGP Rate: 8x
Fast Writes: Disabled
SBA: Enabled

Clight2200 04-26-03 04:02 PM

X hanging until I ssh in
 
Hi

I am using the KT400 workaround. Specifically:-

I've added an options line to my module configuration file, /etc/modules.conf, "options nvidia NVreg_EnableAGPSBA=1", and used the NVIDIA's AGP (Option "NvAGP" "1" in the Screen section of my XF86Config file).

Before when I used to have Option "NvAGP" set to 0 everything was OK, but now KDE occasionally hangs and when I ssh into my box from an external computer the process /etc/X11/X -deferglyphs 16 -auth /var/run/xauth ... is taking all of the CPU time? How can I stop the computer hanging? Anyone got any idea what's happening here?

Help appreciated

Cheers
Ian
Computer Spec
AMD XP 2200+
Gigabyte GA-7VAX (KT 400)
DDR 512MB
GeForce Ti4200 128Mb


All times are GMT -5. The time now is 04:01 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.