View Single Post
Old 04-08-03, 04:32 PM   #1
KoRnaz
Registered User
 
Join Date: Apr 2003
Posts: 18
Send a message via ICQ to KoRnaz
Thumbs down STILL slow Xfree startup on Slackware 9.0, 1.0-4349, GF2 MX

That's it. I had enough of this. After browsing and reading tons of posts all day in this forum I gave up. Of course, most of you already know what do I mean. It's that damn slow Xfree startup with Nvidia Linux drivers. I've never experienced it before, though I knew about it. Yesterday I installed Slack 9.0 and of course 4349 drivers. BOOM! The computer freezes for like 30 secs or so while loading Xfree. The same thing happens when I switch back from a console to Xfree. THIS IS SO ANNOYING!!! I can't understand why the hell this bug isn't fixed yet. Think about it - the problem was reported for the first time like a year ago. And still a lot of people have to deal with this issue! I also tried 3123 drivers - same damn problem. Tried using agpgart, nvagp, enabling "IgnoreDisplayDevices" in the config, as suggested in the README file - still no luck. I even recompiled the kernel without local APIC support. Nothing helped.

Andy, do something. At least promise us that you guys at Nvidia are gonna do something about it. ANY workaround would be greatly appreciated. Your drivers were awesome until 4xxx. I always respected Nvidia for their high quality linux drivers. Don't disappoint us.

And yes, I STILL experience this massive 2D slowdown in Gnome 2.2 as with 41xx drivers. KDE 3.1 runs like a charm, though. Well at least enabling "RenderAccel" option seems to help now, but as far as I understand this option is still experimental. Nvidia, bring back the gool ol' rock solid and stable Linux drivers!

My hardware - DFI AK74-SC mobo (KT133), Duron 700 Mhz, 512 MB SDRAM, Geforce2 MX 32 MB SDRAM.

Slackware 9.0, kernel 2.4.20, Xfree 4.3.0, glibc 2.3.1, gcc 3.2.2, Dropline Gnome 2.2.1.

THANK YOU for reading this.
KoRnaz is offline   Reply With Quote