View Single Post
Old 09-27-06, 01:50 PM   #1
Alejandro Nova
Registered User
 
Join Date: Sep 2006
Posts: 26
Default Composited XVideo flicker

Greetings.

I have a little problem since nVidia began accelerating XVideo with the XComposite extension (8774 and forward, same issue in 9625 beta).

When I want to watch a video in full screen, my screen becomes divided in two horizontally, at a fixed place. The division resembles a Z all across my screen and it reduces if I disable VSync for XVideo, but it does not disappear.

The funny things about it are:
1. When I make my video window transparent the division changes its place, but it does not disappear and remains at its new place. Making the video window opaque makes the division return to its original place.
2. When reduced, this issue isn't evident with low-motion videos. You require high motion videos to see it in all its glory. With VSync enabled, you can see the division in all videos.
3. Before 8774, XV worked perfectly, even with my extremely-high-motion videos (X Japan... those videos flash the screen 15 times a second and, if you have perfect sync, you can see screen flashing and you get into the movie), but with XComposite without acceleration.

So.
1. Is there any way to disable XV acceleration with Composite? I prefer to have perfect sync instead of watch that division.
2. Can you fix the issue (say, syncing better XV to avoid entirely flickering) in 9625 RELEASE?

Specs:
Card: GeForce FX 5500.
Monitor: AOpen LCD, 1280x1024
Refresh rate: 72 Hz

Thanks in advance.

Alejandro Nova™.

Last edited by Alejandro Nova; 09-29-06 at 10:23 AM.
Alejandro Nova is offline   Reply With Quote