View Single Post
Old 10-11-06, 07:42 AM   #4
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: Unified Xen and real-time preemption patch for 1.0-9625

Quote:
Originally Posted by cheval-maxime
I'am running ubuntu (egdy eft 2.6.17-10), how can i apply this patch?
Please try this:

Boot your system with a "normal" kernel (no xen or rt) and install the
nvidia driver package as appropriate for your distribution. Then
perform the following steps (assuming the driver package and
the patch are located in the same directory and you are logged
in as root):

Code:
sh NVIDIA-Linux-x86-1.0-9625-pkg1.run --extract-only
cd NVIDIA-Linux-x86-1.0-9625-pkg1/usr/src/nv
patch -p1 < ../../../../patch-nv-1.0-9625-xenrt.txt
make SYSSRC=$KERNEL_SOURCE_DIR module
cp nvidia.ko $KERNEL_VIDEODRIVER_DIR
depmod -a $KERNEL_VERSION
where

$KERNEL_SOURCE_DIR is something like
"/usr/src/kernels/2.6.17-1.2187_FC5xen0-i686"

$KERNEL_VIDEODRIVER_DIR is something like
"/lib/modules/2.6.17-1.2187_FC5xen0/kernel/drivers/video"

$KERNEL_VERSION is something like:
"2.6.17-1.2187_FC5xen0"

regards

Bernhard
JaXXoN is offline   Reply With Quote