View Single Post
Old 10-22-06, 03:20 PM   #1
denial-music.de
Registered User
 
Join Date: Aug 2006
Posts: 4
Default nforce install problems on 2.6.17-*

Hi i try to install the nvidia drivers by this howto at ubuntu edgy amd 64:
http://wiki.ubuntuusers.de/Nvidia_NForce
so in englisch :
----------------------------
1.first get by apt :

build-essential
linux-headers-386 [4]
libqt3-mt
---------------------------

2.extract the drivers
sh NFORCE-Linux-x86.... -x
---------------------------

3.change the code in NFORCE-Linux-x86-***pkg1/nvsound/main/nvmain.c
line 2191

from : MODULE_PARM(vapu_enable, "i");
to : MODULE_PARM(vapu_enable, int, 0444);

and in
NFORCE-Linux-x86-***pkg1/nvsound/main/Makefile.kbuild

line 51 and 53-60
with a # before the code

----------------------------
4. run in NFORCE-Linux-x86***-pkg1/nvsound/main

make sudo
make install
sudo depmod -a
sudo modprobe nvsound


my problem is : when i do "make sudo" i get :
-----------------
make sudo
make[1]: *** No rule to make target `sudo'. Stop.
make: *** [sudo.o] Error 2
-----------------
when i do sudo make :

----------------------------------
/home/bart/Desktop/NFORCE-Linux-x86_64-1.0-0310-pkg1/nvsound/main/nvmain.c:2191: error: expected ‘)’ before ‘int’
make[3]: *** [/home/bart/Desktop/NFORCE-Linux-x86_64-1.0-0310-pkg1/nvsound/main/nvmain.o] Error 1
make[2]: *** [_module_/home/bart/Desktop/NFORCE-Linux-x86_64-1.0-0310-pkg1/nvsound/main] Error 2
---------------------------
please help !!!! ;o)
denial-music.de is offline   Reply With Quote