View Single Post
Old 08-22-02, 11:00 AM   #26
mad
Guest
 
Posts: n/a
Default RH 2.4.18-5 and NVidia drivers

I have downloaded NVIDIA_kernel-1.0-2960.src.rpm and NVIDIA_GLX-1.0-2960.src.rpm.

I uninstalled all nvdriver and glx software on the system. I booted to 2.4.18-5 RH.

I tried to build both packages

rpm --rebuild pkgs

However the NVIDIA_kernel-1.0-2960.src.rpm
failed to build on 2.4.18-5
-----------------
In file included from /usr/include/linux/highmem.h:5,
install: cannot stat `NVdriver': No such file or directory
...
error: Bad exit status from /var/tmp/rpm-tmp.33750 (%install)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.33750 (%install)
from nv.c:63:
/usr/include/asm/pgalloc.h:6:24: asm/fixmap.h: No such file or directory
make: *** [nv.o] Error 1
+ exit 0
-----------------------

I rebooted back to 2.4.18-4 and was successfully able to build both pkgs.
  Reply With Quote