Thread: glx not loading
View Single Post
Old 11-05-06, 06:39 AM   #1
bathat
Registered User
 
Join Date: Mar 2006
Posts: 11
Default glx not loading

Greetings,
My X server is unable to load glx. I don't think I've ever been successful in this regard through all my troubles with the nvidia driver (driver was never at fault). I'm just glad I finally have the driver working reliably but I've been wanting hardware acceleration for a long time so I'd really like to get glx working... after all, it would sort of defeat the purpose of the proprietary driver if it refuses.

I'm using the 1.0-9625 beta driver btw.

glxinfo:
Code:
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
/var/log/Xorg.0.log:
Code:
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.

(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
There is no glx module available for loading.

Am I missing something here...
Thanks
bathat is offline   Reply With Quote