View Single Post
Old 04-17-03, 09:16 PM   #1
atlas
Registered User
 
Join Date: Apr 2003
Posts: 22
Default Quake III on RH9

Okay, I am stumped. I have installed Q3A as per instructions (Install demo, copy pak0.pk3 from CD, etc.). Runs fine. I installed the 1.32 patch. Now when I run it, I get the following output:

[root@xyz dl]# /usr/local/games/q3demo/quake3

Q3 1.32 linux-i386 Oct 7 2002
----- FS_Startup -----
Current search path:
/root/.q3a/baseq3
/usr/local/games/q3demo/baseq3/pak8.pk3 (9 files)
/usr/local/games/q3demo/baseq3/pak7.pk3 (4 files)
/usr/local/games/q3demo/baseq3/pak6.pk3 (64 files)
/usr/local/games/q3demo/baseq3/pak5.pk3 (7 files)
/usr/local/games/q3demo/baseq3/pak4.pk3 (272 files)
/usr/local/games/q3demo/baseq3/pak3.pk3 (4 files)
/usr/local/games/q3demo/baseq3/pak2.pk3 (148 files)
/usr/local/games/q3demo/baseq3/pak1.pk3 (26 files)
/usr/local/games/q3demo/baseq3/pak0.pk3 (3539 files)
/usr/local/games/q3demo/baseq3
./quake3.x86/baseq3

----------------------
4073 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 3: 640 480
Error couldn't open the X display
...WARNING: could not set the given mode (3)
Received signal 11, exiting...

This is perplexing, as I can Ctrl+Alt+keypad switch to the different resolutions, including 640x480.

????????

Chris
atlas is offline   Reply With Quote