View Single Post
Old 11-10-06, 02:13 PM   #7
Nias
Registered User
 
Join Date: Aug 2004
Posts: 24
Default Re: 9629 driver and modelines

Quote:
Originally Posted by netllama
You've disabled use of the EDID:
(**) NVIDIA(0): Option "UseEDID" "FALSE"
yes i did this with intention.

Quote:
Originally Posted by netllama
As a result, no modes can be validated against the EDID.

However, here's why your custom mode is failing to work:
(II) NVIDIA(1): Validating Mode "1280x720@50":
(II) NVIDIA(1): 1280 x 720 @ 50 Hz
(II) NVIDIA(1): Mode Source: X Configuration file ModeLine
(II) NVIDIA(1): Pixel Clock : 62.16 MHz
(II) NVIDIA(1): HRes, HSyncStart : 1280, 1320
(II) NVIDIA(1): HSyncEnd, HTotal : 1488, 1640
(II) NVIDIA(1): VRes, VSyncStart : 720, 722
(II) NVIDIA(1): VSyncEnd, VTotal : 723, 758
(II) NVIDIA(1): H/V Polarity : +/+
(WW) NVIDIA(1): Mode is rejected: Mode (1280 x 720) is too large for DFP
(WW) NVIDIA(1): Native Resolution (Max: 640 x 480).
yes, i also have found this.
But why the mode has worked with all previous driver versions?

And why the mode was rejected, "too large" is not a reason without telling which setting is to low for this mode?

Furthermore seems UseEdid not a device dependent setting. Because i must uncomment it in booth sections (CRT and DFP) to get the modes working. Is it generally not possible to enable Edid for one Output device and disable it for another?

Next problem, if the beamer is off, there is no edid possible. How can i start X anyway with DFP at 1280x720@50 resolution? I don't want to restart X everytime i'm powering on my beamer.
Nias is offline   Reply With Quote