View Single Post
Old 11-11-06, 03:59 PM   #1
cboehme1
Registered User
 
Join Date: Nov 2006
Posts: 2
Unhappy 7900 gs no 3d accelaration

Update: My bad: I relied on the wrong tools, gnome-xgl-settings and glxgears. Turned out, manually setting Xgl as X-server worked without hitch...

OK, I tried the whole day to get my new 7900gs based card working with Linux (vanilla SuSE 10.1 for x64). It works flawlessly in Winxp; the 6600gt based card I had before also worked well within SuSE.

The problem is that I can't activate 3D accel: glxgears is slow and gnome-xgl-settings says I need to activate 3D. glxinfo says direct rendering is activated, the nvidia module is loaded, and I don't see any errors in in Xorg.0.log (no EE marked lines). I have tried NVIDIA-Linux-x86_64-1.0-8776-pkg2.run and NVIDIA-Linux-x86_64-1.0-9629-pkg2.run without luck.

Interesting sections from xorg.conf:
Section "Module"
Load "type1"
Load "dbe"
Load "freetype"
Load "glx"
Load "v4l"
Load "extmod"
EndSection

Section "Device"
BoardName "GeForce 7900 GS"
BusID "5:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
EndSection

It was created by sax. I have attached the nvidia bug report. Any ideas?
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (29.1 KB, 118 views)

Last edited by cboehme1; 11-11-06 at 04:24 PM. Reason: Update
cboehme1 is offline   Reply With Quote