View Single Post
Old 11-12-06, 01:44 AM   #26
skunkydog
Registered User
 
Join Date: Nov 2006
Posts: 1
Default Re: is nForce MCP61 supported in Linux?

Quote:
Originally Posted by elconqueror
Great, I managed to have the sata, network and ide dma work perfectly, The only thing left is the soundcard. As you requested, here is the output of lspci:
let me know if you also need the output of lspci -v

Thanks again!

00:00.0 RAM memory: nVidia Corporation: Unknown device 03ea (rev a1)
00:01.0 ISA bridge: nVidia Corporation: Unknown device 03e0 (rev a2)
etc.
I have an Acer AST180-ED380M desktop with the exact same lspci. I think it is an MSI motherboard. The BIOS flashes 09/14/2006 MCP61M-AM-6A62KE11C-00 on the bottom of the screen during POST.

I got sata and sound but not ide dma or network. I think you may need the snd-hda-intel and snd_hda_codec modules for sound. Here's what I tried (quoting myself replying on another forum)
Quote:
Mine's working now. I tried installing alsa-tools and alsa-oss but I also downloaded alsa-drivers so I don't know what worked. lsmod now shows:

snd_hda_intel 21528 1
snd_hda_codec 172544 1 snd_hda_intel
snd_pcm_oss 47232 0
snd_mixer_oss 19584 1 snd_pcm_oss
snd_pcm 84996 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 24964 1 snd_pcm

at least the first 2 of which were not there before.
The mixer shows the device as HDA NVidia and gamix as HDA NVidia: Realtek ALC888.

I just built this so if I do it again, I'll be careful to see what does it.
Since we have the same lspci, I can send you my lsmod and you can see what you are missing. Hope it helps. Either way, can you tell me how you got network and especially ide dma working?!

Thanks!

Edit: It sounds like you used forcedeth to get networking going? What about dma?
Edit: The forcedeth modification did not work for me.
Edit: upgrading kernel to 2.6.18.2 let me enable dma, but it is piss slow 3MB/s.
Edit: kernel 2.6.19-rc6 enabled my network card, sound still works, and dma works well. This page explains how to enable SATA support - it is disabled by default. I didn't enable SATA the first time and my system couldn't find /dev/sda1 to boot off of.

Last edited by skunkydog; 11-19-06 at 02:34 AM.
skunkydog is offline   Reply With Quote