View Single Post
Old 11-13-06, 07:40 PM   #1
miragedarksun
Registered User
 
Join Date: Jun 2006
Posts: 22
Default Toshiba and 9629 (yeah I know, please bear with me)

This is yet another thread regarding a Toshiba Satellite 1410-304 with a GF4 420 Go. I've read other threads but none seem to describe exactly my problem, and I've tried to provide all the info I could about it.

The highest version that i can use is 8776. It still requires a trick, of course, which is:

Code:
Option "ExactModeTimingsDVI" "true"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck"
AFAIK this is because EDID reports 969x768 as the native resolution, which is incorrect (should be 1024x768) but somehow the driver has been working for these past years.
And I use these module parameters:

Code:
NVreg_SoftEDIDs=0 NVreg_Mobile=2
Now, i've been trying all 9xxx and all failed with these and other options. With 9629, however, i've got it almost working. This was because "NoEdidDFPMaxSizeCheck" no longer exists, and the closest ModeValidation option in 9629 seems to be "NoDFPNativeResolutionCheck". So I tried it, but now the mode fails because of:

Code:
(WW) NVIDIA(0):     Mode is rejected: Mode (1024 x 768) is too large for DFP
(WW) NVIDIA(0):     Native Resolution (Max: 969 x 768).
Then I tried setting "ExactModeTimingsDVI" to "true" again (like I did with 8776) and now 1024x768 is accepted, but I only get a white screen at first, and soon after, a black screen with only a single line at the top. To make this more interesting, when I switch to console, I could swear I can see the gdm login for a fraction of second, before the console appears.

So my question is, how can I convince the driver that 969 x 768 is bogus, when "ExactModeTimingsDVI" is false? Or, how can I correct the display output, when "ExactModeTimingsDVI" is true? One of these should work with just a little extra effort.

Attached are the logs for 8776, 9626 with "ExactModeTimingsDVI", and 9626 without "ExactModeTimingsDVI". Thanks a lot for your attention.
miragedarksun is offline   Reply With Quote