View Single Post
Old 11-14-06, 01:24 PM   #4
Rede
Registered User
 
Join Date: Jan 2005
Posts: 4
Default Re: Nvidia 5200 and wide screen

I am also using an Nvidia GeForce 5200FX and am having some similar problems with my display.

I have my xorg.conf set up for multi-monitor mode with an 1024x768 monitor as my primary display and my 16x9 LCD TV running at 1366x768 as the second monitor. The second display is a second X session, not twinview, and is connected via the DVI-out with a DVI=>VGA converter and a VGA cable.

The problem is that the display is discolored (orange tint), has a weird black bar down the left side of the screen, and the top of the screen kind of fades into blue. It works perfectly if I set the resolution to 1024x768, but then the aspect ratio is incorrect. I am using the 9629 driver on ubuntu edgy. Previously, with Dapper and the 8XXX series driver it worked as expected.

My xorg.conf (applicable sections):

Code:
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "NEC LCD1515"
    Option         "dpms"
    # 1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz
    Modeline        "1024x768@60"  64.11  1024 1080 1184 1344  768 769 772 795 -HSync +Vsync
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Monitor Vendor"
    ModelName      "RCA L26W11"
    Option         "dpms"
    # 1368x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 85.86 MHz
    Modeline "1368x768@60"  85.86  1368 1440 1584 1800 768 769 772 795  +HSync +Vsync
EndSection

Section "Device"
    Identifier     "nvidia0"
    Driver         "nvidia"
    VendorName     "NVIDIA"
    BoardName      "NVIDIA GeForce FX (generic)"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "nvidia1"
    Driver         "nvidia"
    VendorName     "NVIDIA"
    BoardName      "NVIDIA GeForce FX (generic)"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "nvidia0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "nvidia1"
    Monitor        "Monitor1"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1366x768"
    EndSubSection
EndSection
Rede is offline   Reply With Quote