View Single Post
Old 11-19-06, 11:25 AM   #1
_SAS
Registered User
 
Join Date: Nov 2006
Posts: 1
Default Legacy drivers with FreeBSD 6.0 troubles

It seems that make tries to compile libs for Linux compatibility, but it can't install them because I turned Linux binary compatibility off. How can I disable compiling of lib/compat?
Here is the log:
Code:
sas# make install
===> src (install)
install -o root -g wheel -m 555   nvidia.ko /boot/modules
kldxref /boot/modules
===> lib (install)
find: /compat/linux/lib: No such file or directory
find: /compat/linux/usr/lib: No such file or directory
find: /compat/linux/usr/X11R6/lib: No such file or directory
===> lib/libGL (install)
===> lib/libnvidia-tls (install)
===> lib/libGLcore (install)
===> lib/libXvMCNVIDIA (install)
===> lib/compat (install)
===> lib/compat/libGL (install)
install: /compat/linux/usr/lib: No such file or directory
*** Error code 71

Stop in /usr/home/andrew/g/NVIDIA-FreeBSD-x86-1.0-7184/lib/compat/libGL.
*** Error code 1

Stop in /usr/home/andrew/g/NVIDIA-FreeBSD-x86-1.0-7184/lib/compat.
*** Error code 1

Stop in /usr/home/andrew/g/NVIDIA-FreeBSD-x86-1.0-7184/lib.
*** Error code 1

Stop in /usr/home/andrew/g/NVIDIA-FreeBSD-x86-1.0-7184.
_SAS is offline   Reply With Quote