View Single Post
Old 11-22-06, 09:17 AM   #1
RipTide1024
Registered User
 
Join Date: Nov 2006
Posts: 2
Question Segfault starting X -- dual head setup

So when I start up X, I get the Nvidia label displayed on both monitors and then as it tries to bring up the X displays, it segfaults.

My xorg.conf is kinda pieced together from different configs I found around on the net, so I wouldn't be surprised if I have missed something stupid. I have pasted my xorg.conf followed by a tail of /var/log/Xorg.0.log.

The card is detected by xorg as:
(--) PCI:*(1:0:0) nVidia Corporation NV34 [GeForce FX 5200] rev 161, Mem @ 0xfc0
00000/24, 0xf0000000/27

I don't know if it matters, but I was reading a lot about dual head displays with a DVI and a VGA -- my setup here (work computer) has only a DVI connector with a splitter attached to connect two VGAs to it.

Oh, and my driver version is 1.0.9629

Any help will be much appreciated.

---------------------xorg.conf--------------
Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "NVIDIA GeForce FX 5200 head 1"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 0 #For separate screen dual heads

EndSection


Section "Device"
Identifier "NVIDIA GeForce FX 5200 head 2"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 1 #For separate dual heads
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Dell 1800FP (Digital)"
HorizSync 30.0 - 70.0
VertRefresh 56.0 - 85.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell 1907FP (Digital)"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Screen"
Device "NVIDIA GeForce FX 5200 head 1"
Identifier "Screen0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Device "NVIDIA GeForce FX 5200 head 2"
Identifier "Screen1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
Option "Xinerama"
InputDevice "Generic Keyboard"
EndSection

Section "DRI"
Mode 0666
EndSection

-----------------End Config-------------
-----------------Xorg.0.log tail-------------
....
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Damage Notification Manager" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Kernel RC Handler" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80e53b1]
1: [0xddd420]
2: /usr/bin/Xorg(PanoramiXConsolidate+0x165) [0x8136215]
3: /usr/bin/Xorg(main+0x6d8) [0x806fcb8]
4: /lib/libc.so.6(__libc_start_main+0xdc) [0x4fff0f2c]
5: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e9) [0x806eda1]

Fatal server error:
Caught signal 11. Server aborting

(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
RipTide1024 is offline   Reply With Quote