View Single Post
Old 11-22-06, 11:03 AM   #6
Cambo
Registered User
 
Join Date: Mar 2004
Location: UK
Posts: 128
Send a message via Yahoo to Cambo
Default Re: resolution 1440x900 problem

@greviant: It looks like the driver cannot read the EDID info from your monitor;

Quote:
(--) NVIDIA(0): Connected display device(s) on GeForce 6800 Ultra at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): @@@ (CRT-1)
(--) NVIDIA(0): @@@ (CRT-1): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-1
(WW) NVIDIA(0): No valid modes for "1400x1050"; removing.
(WW) NVIDIA(0): No valid modes for "1280x1024"; removing.
(WW) NVIDIA(0): No valid modes for "1152x864"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "800x600"; removing.
(WW) NVIDIA(0): No valid modes for "640x480"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
http://www.viewsonic.com/products/de...ies/e70/#specs has the specs for your monitor. Editting your Monitor Section of your /etc/X11/xorg.conf may help. Try;

Quote:
Section "Monitor"
Identifier "ViewSonic E70"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection
According to the specs page, the maximum resolution for your monitor is only 1280x1024.

When it comes to the refresh rate that you can see, bear in mind that the Nvidia driver actually changes the numeric value, so that XRandR does not get confused - there are several posts referencing this, and it's in the driver's README file.



Cambo
Cambo is offline   Reply With Quote