View Single Post
Old 11-23-06, 05:47 AM   #2
bstabile
Registered User
 
Join Date: Nov 2006
Posts: 4
Exclamation Re: limited resolution: FX5500, DVI, DFP Widescreen

I have the same problem: my screen with drivers nv or nvidia under Windows runs at 1024x768, but with nvidia driver under Linux it runs at 800x600.
I have seen that a part of the screen (at left) is blank, and that nvidia-settings tells me that my screen is 969x768!!!
I think this is the real problem: nvidia driver don't view all screen.

My hardware is:
  • GeForce4 420 Go
  • TFT Screen 14,1''

My sotware:
  • Debian Gnu/Linux testing
  • NVidia driver 1.0-9629
  • xorg 7.1.0
  • kernel linux 2.6.18-2-686

I have tested a lot of configuration, but all give me same results: 800x600
With option "UseEdid" to "false" my screen become crazy.

My last xorg.conf with nvidia driver:

Quote:
...
Section "Monitor"
Identifier "Monitor Generico"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
Modeline "1024x768_60_0" 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync
Modeline "1024x768_60_1" 64.56 1024 1056 1296 1328 768 783 791 807
Modeline "1024x768_70i" 34.43 1024 1056 1184 1216 768 785 790 807 interlace
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV17 [GeForce4 420 Go]"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "NoLogo" "true"
EndSection

Section "Screen"
Identifier "Default Screen"
Option "ExactModeTimingsDVI"
Option "UseEdidDpi" "FALSE"
Option "AddARGBGLXVisuals" "True"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"
Device "NVIDIA Corporation NV17 [GeForce4 420 Go]"
Monitor "Monitor Generico"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768_60_0" "1024x768_60_1" "1024x768_70i" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768_60_0" "1024x768_60_1" "1024x768_70i" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768_60_0" "1024x768_60_1" "1024x768_70i" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768_60_0" "1024x768_60_1" "1024x768_70i" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768_60_0" "1024x768_60_1" "1024x768_70i" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768_60_0" "1024x768_60_1" "1024x768_70i" "1024x768" "800x600"
EndSubSection
EndSection
...

log file of xorg with nv driver tells me:

Quote:
...
(**) NV(0): *Default mode "1024x768": 75.0 MHz, 56.5 kHz, 70.1 Hz
(II) NV(0): Modeline "1024x768" 75.00 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
(**) NV(0): Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(II) NV(0): Modeline "1024x768" 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
(**) NV(0): Default mode "800x600": 50.0 MHz, 48.1 kHz, 72.2 Hz
(II) NV(0): Modeline "800x600" 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync
(**) NV(0): Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(II) NV(0): Modeline "800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
(**) NV(0): Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
(II) NV(0): Modeline "800x600" 36.00 800 824 896 1024 600 601 603 625 +hsync +vsync
(**) NV(0): Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(II) NV(0): Modeline "640x480" 25.20 640 656 752 800 480 490 492 525 -hsync -vsync
(==) NV(0): DPI set to (75, 75)
...
with nvidia driver log file is:
Quote:
...
(II) NVIDIA(0): NVIDIA GPU GeForce4 420 Go at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 16384 kBytes
(--) NVIDIA(0): VideoBIOS: 04.17.00.41.c7
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 420 Go at PCI:1:0:0:
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0)
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): 224.0 MHz maximum pixel
(--) NVIDIA(0): clock
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Mode Validation Overrides for Nvidia Default Flat Panel
(II) NVIDIA(0): (DFP-0):
(II) NVIDIA(0): NoVesaModes
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1024x768_60_0"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768_60_1"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768_70i"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "800x600"
(II) NVIDIA(0): Virtual screen size determined to be 800 x 600
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
...
If somebody have some idea...

Bruno
bstabile is offline   Reply With Quote