View Single Post
Old 11-30-06, 05:49 AM   #1
Martin Reed
Join Date: Aug 2004
Posts: 8
Default xrandr not working after suspend resume cycle


I have a problem with Xranr after a suspend to RAM. It works as many times as I like after a clean start of X but after suspend to RAM it silently ignores any mode switch request. I frequently change between

twinview (with external CRT) <-> single laptop screen <-> clone (for presentations)

a number of times a day so getting this working would be really nice.

It used to work flawlessly on Xorg 6.8 (I think) and an older version of the nvidia driver (7000 series I think). I am not sure which upgrade (Xorg or nvidia driver) stopped it working. The main problem is I am not sure if it is an Xorg problem or an nvidia driver problem so I do not even know where to start asking/looking but am trying here first!

Set up is:

Dell Latitude D820, nVidia Corporation Quadro NVS 110M GeForce Go 7300

Linux 2.6.18 (gentoo suspend2 patches), SMP and PREEMPT enabled, (nv driver and AGP disabled)
Xorg 7.1
nvidia-drivers 1.0.9629
ACPI enabled

nvidia relevant part of Xorg.conf
Section "Device"
	Identifier  "Card0twinview"
	Driver      "nvidia"
	VendorName  "nVidia Corporation"
	BoardName   "Unknown Board"
	BusID       "PCI:1:0:0"
	Option 	    "NvAgp"	"1"
	Option	    "TwinView" "true"
	Option      "TwinViewOrientation" "CRT-0 LeftOf DFP-0"
	Option	    "ConnectedMonitor" "DFP-0, CRT-0"
    Option "SecondMonitorHorizSync"   "50-90"
    Option "SecondMonitorVertRefresh" "59-75"

	Option      "FlatPanelProperties" "Scaling=aspect-scaled"
	Option "MetaModes" "CRT-0: 1024x768 +0+0, DFP-0: 1024x768 +0+0 ; CRT-0: 1280x1024 +0+0, DFP-0: 1680x1050 +1280+0; CRT-0: NULL, DFP-0: 1680x1050 +0+0"
	Option "RenderAccel" "on"
	Option "DPI" "129 x 120"
	Option "ConstantDPI" "false"
	Screen 0
I first noticed this problem on another older Dell Inspiron machine after an Xorg/nvidia upgrade
martinjreed is offline   Reply With Quote