View Single Post
Old 12-03-06, 03:41 AM   #3
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Sharp Aquos EDID FX 5700LE

Have you tried using the 8776 driver?
There seem to be some errors in the EDID of the TV, like that it returns the native resolution of 1280x720 while it actually is 1366x768, but in the log we also see the usual rejects by the driver "because Mode is too large for DFP Native Resolution".
This is a goof-up from NVIDIA. They assume that modes larger than the DFP size should be rejected, even when those timings are handed by the panel itself over EDID.
This is a mistake, because when using a scaling HD TV like this, you may want to use it with a 1920x1080 mode even though the native size is smaller. The TV will scale down that higher resolution to the panel size. No reason to reject or disallow that. But the 9xxx driver blindly rejects this.
(this also causes problems for panels for which the native resolution in the EDID does not match the real value, in which your TV is not alone)

But there also appears to be some confusion about the interlaced mode. Not the first time I have seen this, either.
The 1920x1080 interlaced mode either is calculated as having half the resolution (1920x540) or double the scan frequency (120 Hz) or both. So that ends up getting rejected a well.
Try the following 1080i modeline:

Modeline "1920x1080i60" 74.25 1920 1976 2008 2200 1080 1083 1085 1125 +Hsync +Vsync Interlace

This will give the correct timing. It works on my system. But you will need to go back to an older driver or turn off the agressive checking, as it will be rejected by the new driver as being "too large" as well.
pe1chl is offline   Reply With Quote