View Single Post
Old 12-07-06, 06:05 AM   #1
kaeptn
Registered User
 
Join Date: Dec 2006
Posts: 1
Default 1.0-9631 Composite (6.9.0) and GLX problem

Dear all,

today I upgraded from 1.0.8776 to 1.0-9631. I had enabled X-Composite option and with the 8776 driver I could use GLX together with the X-composite extension on my TwinView x.org 6.9.0.
With the 9631 driver I can't use GLX anymore when X-composite is enabled, if I start glxgears I get 0.2 fps returned by glxgears but can't see any output.
If I disable the X-composite extension GLX is working fine like before.

Nothing noticeable in the logs, at least I couldn't find any difference to the 1.0.8776 logs, so I avoid posting it here.

System is RELENG_6, card is GeForce 7300 GS, xorg.conf appended

Btw. Why are these drivers supposed to rely on compat5? If I simply link /lib/libm.so.4 to /lib/libm.so.3 everything is working fine. Not relevant to this problem because I went the proposed way and compiled compat5 options into the kernel and installed compat5 to make sure it's not my setup which causes the problem.

Thanks a lot,

-Harry

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
# FontPath "/usr/X11R6/lib/X11/fonts/CID/"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/bitstream-vera/"
FontPath "/usr/local/share/ghostscript/fonts/"
FontPath "/usr/local/share/fonts/"
FontPath "/usr/X11R6/lib/X11/fonts/agfa/"
FontPath "/usr/X11R6/lib/X11/fonts/brother/"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/vista"
FontPath "/usr/X11R6/lib/X11/fonts/windows"
EndSection

Section "Module"

# Load "speedo"
# Load "record"
# Load "xtrap"
Load "bitmap" #Like NVIDIA-Readme advises
Load "extmod"
Load "dbe"
Load "type1"
Load "glx"
Load "freetype"
# Load "dri" #no DRI for NVIDIA
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/sysmouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "LG"
ModelName "L1710"
Option "DPMS"
EndSection

Section "Device"
Identifier "GBT GeForce 7300 GS"
Driver "nvidia"
VendorName "nVidia Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "GBT GeForce 7300 GS"
Monitor "Monitor0"
DefaultDepth 24
Option "NvAGP" "3" #Attempt FreeBSD-AGP="2" before NVIDIA-AGP="1"
Option "TwinView"
Option "NoLogo" "0"
Option "UseEdidFreqs" "true"
Option "HorizSync" "CRT-0: 40-70; DFP-0: 40-70"
Option "VertRefresh" "CRT-0: 60; DFP-0: 60"
Option "TwinViewOrientation" "CRT-0 RightOf DFP-0"
Option "MetaModes" "1280x1024,1280x1024"
Option "UseDisplayDevice" "DFP-0, CRT-0"
Option "CursorShadow" "true" #NON-STANDARD
Option "CursorShadowAlpha" "80" #NON-STANDARD
Option "CursorShadowXOffset" "4"
Option "CursorShadowYOffset" "2"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "DamageEvents" "true"
Option "DisableGLXRootClipping" "true"
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Extensions"
# Option "Composite" "Enable"
Option "RENDER" "Enable"
EndSection
kaeptn is offline   Reply With Quote