View Single Post
Old 04-25-03, 02:38 PM   #1
andnaess
Registered User
 
Join Date: Apr 2003
Posts: 5
Default nForce2 on Mandrake 9.1

I tried to get my brand new nForce2 card (Abit NF7-M) up on running under Mandrake 9.1, to no avail. I first attempted a rpm install (using the current rpm from Nvidia). I simply copied the .o files that came with this RPM and tried to run insmode. The result was lots of missing symbol errors, so that didn't work.

I then tried to download the source version, as I ran make, but this failed with a huge error message, parts of which I've added to the end of this posting.

I tried to follow the advises in the error message displayed by the failed compile, but this was unsuccessful.

In the end I had to go back to 9.0 and use the supplied rpm (which works).

Has anyone been able to compile the nforce software under Mandrake 9.1? Does anyone know where I'm going wrong? I'm kind of desperate because I can't seem to find any RPM-files for 9.0, so among other things I can't install the kdenetwork package , which contains two of the programs I use hte most: gaim and knode.

Help!


[root@localhost nforce]# make
make -C nvnet
make[1]: Entering directory `/home/andre/nforce/nvnet'
cc -c -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.19-16mdk/build/include nvnet.c
In file included from /usr/include/linux/prefetch.h:13,
from /usr/include/linux/list.h:6,
from /usr/include/linux/module.h:11,
from nvnet.h:20,
from nvnet.c:21:
/usr/include/asm/processor.h:55: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/processor.h:55: requested alignment is not a constant
In file included from /usr/include/linux/module.h:20,
from nvnet.h:20,
from nvnet.c:21:
/usr/include/linux/modversions.h:1:2: #error "================================================= ======"
/usr/include/linux/modversions.h:2:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/modversions.h:3:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/modversions.h:4:2: #error ""
/usr/include/linux/modversions.h:5:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/modversions.h:6:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/modversions.h:7:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/modversions.h:8:2: #error "currently running kernel. They should only be"
/usr/include/linux/modversions.h:9:2: #error "included via other system header files - user space"
/usr/include/linux/modversions.h:10:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/modversions.h:11:2: #error "<asm/*.h> as well."
/usr/include/linux/modversions.h:12:2: #error ""
/usr/include/linux/modversions.h:13:2: #error "To build kernel modules please do the following:"
/usr/include/linux/modversions.h:14:2: #error ""
/usr/include/linux/modversions.h:15:2: #error " o Have the kernel sources installed"
/usr/include/linux/modversions.h:16:2: #error ""
/usr/include/linux/modversions.h:17:2: #error " o Make sure that the symbolic link"
/usr/include/linux/modversions.h:18:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/modversions.h:19:2: #error " the matching kernel source directory"
/usr/include/linux/modversions.h:20:2: #error ""
/usr/include/linux/modversions.h:21:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/modversions.h:22:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/modversions.h:23:2: #error ""
/usr/include/linux/modversions.h:24:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/modversions.h:25:2: #error " compiler option to use the correct include files:"
/usr/include/linux/modversions.h:26:2: #error ""
/usr/include/linux/modversions.h:27:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/modversions.h:28:2: #error ""
/usr/include/linux/modversions.h:29:2: #error " instead of"
/usr/include/linux/modversions.h:30:2: #error ""
/usr/include/linux/modversions.h:31:2: #error " -I/usr/include/linux"
/usr/include/linux/modversions.h:32:2: #error ""
/usr/include/linux/modversions.h:33:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/modversions.h:34:2: #error "================================================= ======"
andnaess is offline   Reply With Quote