View Single Post
Old 12-19-06, 12:38 AM   #10
NotASquirrel
Certified Non-Sciuridae
 
Join Date: Dec 2006
Location: Generally, not in trees.
Posts: 13
Default Re: Monitor doesnt like Drivers

My non-working xorg.conf follows below and is significantly different from the other guy's. Is that a Gnome vs. KDE thing or is my xorg.conf bad?

Specifically mine does not seem to specify refresh rates anywhere:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Nov  1 19:47:17 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

        # path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
    Option         "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "false"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "stylus"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "eraser"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "cursor"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "synaptics"
  Identifier    "TouchPad"
  Option        "Device"        "/dev/input/mouse0"
  Option        "Protocol"      "audo-dev"
  Option       "LeftEdge"      "1700"
  Option       "RightEdge"     "5400"
  Option       "TopEdge"       "1700"
  Option       "BottomEdge"    "4200"
  Option       "FingerLow"     "25"
  Option       "FingerHigh"    "30"
  Option       "MaxTapTime"    "75"
  Option       "MaxTapMove"    "2"
  Option       "TapButton1"    "0"
  Option       "TapButton2"    "2"
  Option       "TapButton3"    "2"
  Option       "VertScrollDelta" "100"
  Option       "MinSpeed"      "0.09"
  Option       "MaxSpeed"      "0.18"
  Option       "AccelFactor"   "0.0015"
  Option       "SHMConfig"     "on"
  Option       "UpDownScrolling"  "on"
  Option       "UpDownRepeat"  "off"
  Option       "ScrollButtonRepeat"  "300"
  Option       "HorizTwoFingerScroll"  "on"
EndSection


Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       28.0 - 84.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "NVIDIA Corporation NV36 [GeForce FX Go5700]"
    Driver         "nvidia"
    Option         "LoadKernelModule"  "FALSE"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV36 [GeForce FX Go5700]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
#    Option         "ModeValidation" "NoEdidModes"
#    Option         "UseEdidFreqs" "FALSE"
#    Option         "UseEDID" "FALSE"
#    Option         "ModeValidation"  "DFP-0: NoMaxPClkCheck, NoEdidMaxPClkCheck"
    Option         "ModeValidation"  "DFP-0: NoDFPNativeResolutionCheck, AllowNon60HzDFPModes, NoMaxPClkCheck, NoEdidMaxPclkCheck, NoHorizSyncCheck, NoVertRefreshCheck, NoWidthAlignmentCheck, NoVirtualSizeCheck, NoEdidModes, NoMaxSizeCheck, NoVesaModes"
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
To make my system work perfectly again, I pretty much just have to replace 'nvidia' with 'nv' in the device driver section.
NotASquirrel is offline   Reply With Quote