View Single Post
Old 12-26-06, 11:05 PM   #1
sremick
Registered User
 
Join Date: Jul 2006
Posts: 4
Default Upgraded to 9631, now stuck in 800x600 60Hz

Running FreeBSD 6-STABLE ("6.2-PRERELEASE" Nov 2nd) and Xorg 6.9.0

So in running portupgrade -R on some other ports, my nvidia-driver got upgraded to 9631 (the latest in ports). I hadn't rebooted in a long time (good old FreeBSD) but had to today, and on booting back up into X I find myself stuck in 800x600 50Hz unable to change anything (although 24-bit color, interestingly enough). I had been running 1280x1024 and so 800x600 is now quite painful, let alone 50Hz. My card is a GeForce2 MX 400 (AGP).

My xorg.conf has not changed. Here it is for the curious:

Code:
Section "ServerLayout"
        Identifier     "XFree86 Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"
        FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
#       FontPath     "/usr/X11R6/lib/X11/fonts/Speedo/"
        FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
        FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
        FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
        FontPath     "/usr/X11R6/lib/X11/fonts/webfonts/"
        FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
EndSection

Section "Module"
        Load  "extmod"
#       Load  "xie"
#       Load  "pex5"
        Load  "glx"
        Load  "dri"
        Load  "dbe"
        Load  "record"
        Load  "xtrap"
#       Load  "speedo"
        Load  "type1"
        Load  "freetype"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
#       Option      "Buttons" "5"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "KDS"
        ModelName    "VS-19sn"
        HorizSync    28 - 95
        VertRefresh  50 - 120
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "HWcursor"                  # [<bool>]
        #Option     "NoAccel"                   # [<bool>]
        #Option     "ShowCache"                 # [<bool>]
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "UseFBDev"                  # [<bool>]
        #Option     "Rotate"                    # [<str>]
        #Option     "VideoKey"                  # <i>
        #Option     "FlatPanel"                 # [<bool>]
        Identifier  "Card0"
        #Driver      "nv"
        Driver      "nvidia"
        VendorName  "NVidia"
        BoardName   "GeForce2 MX/MX 400"
        BusID       "PCI:1:0:0"
        # NvAGP: 0=disable, 1=nvidia's AGP, 2=FreeBSD AGP
        Option      "NvAgp" "1"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Depth     24
                Modes   "1280x1024" "1024x768" "800x600"
        EndSubSection
EndSection

Section "Extensions"
#       Option "Composite" "Enable"
EndSection
sremick is offline   Reply With Quote