View Single Post
Old 04-27-03, 07:03 PM   #2
Andy Kunzmann
Registered User
 
Join Date: Apr 2003
Location: Switzerland, Lenzburg
Posts: 2
Angry

Hi. I installed Suse 8.1 as well as Suse 8.2 on my Shuttle XPC (SN41G2). In neither of these versions I could get the Ethernet (nvnet) to work.
Downloading the binary rpms from www.nvidia.com and installing the package as described did not work. Loading down the rpm sources and recompile them didn't work neither.

I make the following observations:

Neither in the outputs of dmesg.txt nor of lsmod nvnet is mentioned. I put the entries into /etc/moduls.conf as described in the description.

modprobe nvnet gives the following output, although nvnet.o is in the directory mentioned in the errormessage:

linux:/usr/src/packages/RPMS/athlon/NVIDIA # modprobe nvnet
Warning: loading /lib/modules/2.4.20-4GB-athlon/kernel/drivers/net/nvnet.o will taint the kernel: non-GPL license - NVIDIA
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/net/nvnet.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/net/nvnet.o: insmod /lib/modules/2.4.20-4GB-athlon/kernel/drivers/net/nvnet.o failed
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/net/nvnet.o: insmod nvnet failed
linux:/usr/src/packages/RPMS/athlon/NVIDIA #

An other strange behaviour I don't understand. Installing the driver manually with rpm -i does show up in Yast2-Packet overview. But:

linux:/usr/src/packages/RPMS/i386 # rpm -e NVIDIA_nforce-1.0-0256.i386.rpm
error: package NVIDIA_nforce-1.0-0256.i386.rpm is not installed
linux:/usr/src/packages/RPMS/i386 # rpm -i NVIDIA_nforce-1.0-0256.i386.rpm
linux:/usr/src/packages/RPMS/i386 # rpm -q -s NVIDIA_nforce-1.0-0256.i386.rpm
package NVIDIA_nforce-1.0-0256.i386.rpm is not installed
linux:/usr/src/packages/RPMS/i386 #


Any hints are wellcome. I have to bring the computer to work till next Tuesday (April 29., 2003) because I can bring back the SN41G2 till then, if it does not work.

Thank you in advance.

Andy
Attached Files
File Type: txt problems.txt (1.1 KB, 194 views)
Andy Kunzmann is offline   Reply With Quote