View Single Post
Old 04-28-03, 10:08 PM   #7
briansladecek
Registered User
 
Join Date: Apr 2003
Location: United States
Posts: 21
Default

Howdy,

Steven, keep the change I gave you earlier. You definitely want the "hda2" option and *not* "hda1". That, I'm sure of...

I think what problem you may be having is this. You use a ram disk I believe. I think I saw "initrd" in the last line of either kernel entry. With that said, you can run into danger passing the "mem=" option (*if* you specify a number less than the actual system memory).

I'm not sure of your exact setup, machine, etc...but here's what I would do:

Remove the "mem=" option at the end of the line which loads your kernel. You can also remove the usage of "initrd" and still boot, but you just won't have a ram disk, and may get an init script error.

Whatever the case, try that, reboot and see what happens.

* I remember seeing earlier how you installed grub, and that part is correct. You went into the grub shell and did all the commands you needed to.

I assume that, *without* using a floppy disk, you can boot from hda but grub just bombs when trying to load the kernel. If I understand correctly, you just use the boot disk so that you can at least get back into the OS and make any changes.

Another suggestion would be to check the `grub.conf' or `menu.1st' file on your floppy and compare those options against the `grub.conf' on your hard drive.

Hope that helps...

I'm a little confused on how some of those options got in your `grub.conf' to begin with since I've used a ram disk ("initrd") before and my `grub.conf' never had that "mem=" option...and it worked fine. I assume the normal install created all those options? If so, did you change any of the default grub install options during the initial setup of Redhat. I think you do have the option of setting some of those with the "Advanced Options" menu entry during the initial install.

thanks,

Brian Sladecek
briansladecek is offline   Reply With Quote