View Single Post
Old 01-03-07, 01:35 PM   #1
hufigo
Registered User
 
Join Date: Jan 2007
Posts: 2
Default GeForce 420 Go on Kubuntu6.10:Desktop fixed on 800*600 rectangle area,not full screen

My System:
Toshiba 6100 pro/GeForce4 420 Go/Kubuntu 6.10 Edgy

Hi,everyone.
I installed the 9631(NVIDIA-Linux-x86-1.0-9631-pkg1.run) on my laptop yesterday.
And modified some options in options below:

/etc/modpro.d/
Quote:
options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1
/etc/X11/xorg.conf
Quote:
Option "UseDisplayDevice" "DFP"
Option "ExactModeTimingsDVI"
Option "UseEdidDpi" "FALSE"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"
After reboot, X and render works but the Desktop is just a 800*600 rectangle in the center of screen, it is not full screen, some black backgound aound(like snapshot.jpg in attachment)!

then i checked /var/log/xorg.0.log
I found some lines like:

Quote:
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 800 x 600
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in defaul

I cannot get any resolution above 800*600 in nVidia Configure.
And i set 1024*768 in my xorg.conf,but it did not work.

i need EDID.bin file to fix this?
thx in advance.
Attached Thumbnails
Click image for larger version

Name:	snapshot.jpg
Views:	132
Size:	43.8 KB
ID:	23242  
Attached Files
File Type: log nvidia-bug-report.log (114.0 KB, 103 views)
File Type: log Xorg.0.log (24.5 KB, 118 views)

Last edited by hufigo; 01-03-07 at 02:42 PM.
hufigo is offline   Reply With Quote