View Single Post
Old 04-29-03, 11:05 AM   #1
daclink
Registered User
 
Join Date: Apr 2003
Posts: 23
Default glxgears seems a bit slow with nforce2 IGP

Hi... whenever i run glxgears i about 840 fps... i think i'm right in thinking this i low. I think i have hardware acceleration turned on (correct me if i'm wrong!), but i'm running out of ideas.

i'm running an nforce2 chipset with an integrated geforce 4 mx.
Xfree 4.3.0
Drivers: 4363
Athlon XP 2100
256MB RAM


Any suggestions would be appreciated

DaClink


XF86Config:

Section "Module"

Load "dbe" # Double buffer extension

SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

Load "type1"
Load "speedo"
# Load "freetype"
# Load "xtt"
Load "glx"
# Load "dri"

EndSection

Section "Files"

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
# FontPath "/usr/X11R6/lib/X11/fonts/TrueType/"
# FontPath "/usr/X11R6/lib/X11/fonts/freefont/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

# ModulePath "/usr/X11R6/lib/modules"

EndSection


Section "ServerFlags"

EndSection


Section "InputDevice"

Identifier "Keyboard1"
Driver "Keyboard"

Option "AutoRepeat" "500 30"

Option "XkbRules" "xfree86"
Option "XkbModel" "microsoftinet"
Option "XkbLayout" "gb"

EndSection



Section "InputDevice"


Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
Option "Resolution" "512"


EndSection



Section "Monitor"

Identifier "56i"
HorizSync 31.5 - 64.3
VertRefresh 50-90

EndSection


Section "Device"
Identifier "G4"
Driver "nvidia"
VideoRam 65536
# Insert Clocks lines here if appropriate

Option "NvAGP" "3"
Option "RenderAccel" "true"
EndSection



Section "Screen"
Identifier "Screen 1"
Device "G4"
Monitor "56i"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection



Section "ServerLayout"

Identifier "Simple Layout"

Screen "Screen 1"

InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection

# Section "DRI"
# Mode 0666
# EndSection
daclink is offline   Reply With Quote