View Single Post
Old 01-05-07, 11:15 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Wrongly rejected interlaced modes from EDID?

The only defined 1920x1080 mode in the EDID is:
(--) NVIDIA(0): 1920 x 1080 @ 60 Hz
(--) NVIDIA(0): Pixel Clock : 74.18 MHz
(--) NVIDIA(0): HRes, HSyncStart : 1920, 2008
(--) NVIDIA(0): HSyncEnd, HTotal : 2052, 2200
(--) NVIDIA(0): VRes, VSyncStart : 540, 542
(--) NVIDIA(0): VSyncEnd, VTotal : 547, 562
(--) NVIDIA(0): H/V Polarity : +/+
(--) NVIDIA(0): Extra : Interlaced
(--) NVIDIA(0): CEA Format : 5

However, its actually 1920x540 since its interlaced. That mode is failing validation:
(II) NVIDIA(0): Validating Mode "1920x1080":
(II) NVIDIA(0): 1920 x 540 @ 60 Hz
(II) NVIDIA(0): Mode Source: EDID
(II) NVIDIA(0): Pixel Clock : 74.25 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0): HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0): VRes, VSyncStart : 540, 542
(II) NVIDIA(0): VSyncEnd, VTotal : 547, 562
(II) NVIDIA(0): H/V Polarity : +/+
(II) NVIDIA(0): Extra : Interlace
(WW) NVIDIA(0): Mode is rejected: VertRefresh (120.1 Hz) out of range
(WW) NVIDIA(0): (59.000-61.000 Hz).

You can attempt to workaround that by adding the following to the Device section of xorg.conf:
Option "ModeValidation" "NoVertRefreshCheck"

However, you're not requesting any modes in your xorg.conf, so if you want 1920x1080, you'll need to explicitly request it.

The native resolution can only be determined from the EDID.
netllama is offline   Reply With Quote