View Single Post
Old 01-16-07, 10:33 AM   #1
baswesterbaan
Registered User
 
Join Date: Jan 2007
Posts: 11
Default kernel page fault on modprobe of 9746's nvidia.ko

When I modprobe the nvidia module it kernel-page-faults on ffffffff6d723538 in os_get_cpu_frequency+0xb. From dmesg:

Code:
Unable to handle kernel paging request at ffffffff6d723538 RIP: 
 [<ffffffff6d723538>]
PGD 203027 PUD 0 
Oops: 0010 [1] PREEMPT SMP 
CPU 0 
Modules linked in: nvidia(P) bcraid
Pid: 7028, comm: modprobe Tainted: P      2.6.19-gentoo-r4 #1
RIP: 0010:[<ffffffff6d723538>]  [<ffffffff6d723538>]
RSP: 0018:ffff81003b25de40  EFLAGS: 00010296
RAX: 0000000000181b00 RBX: ffff81003b25de98 RCX: 00000000078bfbff
RDX: 0000000000181100 RSI: 0000000000000001 RDI: ffff81003ddef000
RBP: ffff81003ddef000 R08: ffff81003b25de8c R09: ffff81003b25de88
R10: 0000000000000002 R11: 0000000000000001 R12: ffffffff88848380
R13: 00002ae561bda010 R14: 00000000005080f8 R15: 00002ae561bda010
FS:  00002ae561bd8ae0(0000) GS:ffffffff80691000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: ffffffff6d723538 CR3: 000000003bdf7000 CR4: 00000000000006e0
Process modprobe (pid: 7028, threadinfo ffff81003b25c000, task ffff81003df1f880)
Stack:  ffffffff88426e17 0000000000000286 ffff81003b25de98 ffff81003ddef000
 ffffffff88119bbd ffff81003b25de98 ffffffff88104316 ffff81003b25de90
 0000000000003200 0000080000000000 00000f5a078bfbff 69746e6568747541
Call Trace:
 [<ffffffff88426e17>] :nvidia:os_get_cpu_frequency+0xb/0x44
 [<ffffffff88119bbd>] :nvidia:_nv003359rm+0x9/0xe
 [<ffffffff88104316>] :nvidia:_nv002562rm+0x1f6/0x362
 [<ffffffff881079ce>] :nvidia:_nv002556rm+0x80/0xa6
 [<ffffffff88122751>] :nvidia:rm_init_rm+0x9/0xe
 [<ffffffff8884e0e3>] :nvidia:nvidia_init_module+0xe3/0x7aa
 [<ffffffff802215cf>] __up_read+0x13/0x8a
 [<ffffffff8029aa76>] sys_init_module+0xaf/0x227
 [<ffffffff8025ba1e>] system_call+0x7e/0x83


Code:  Bad RIP value.
RIP  [<ffffffff6d723538>]
 RSP <ffff81003b25de40>
CR2: ffffffff6d723538
I do experience similar problems with 9742, but not with 9631 (which randomly crashes though, that's the reason I upgraded).

I cannot remove the module with rmmod, it seems to be stuck initializing due to this page-fault. When letting Xorg load the nvidia module, it'll crash in the same way. (Although the input freezes I ascertained this via ssh)
Attached Files
File Type: log nvidia-bug-report.log (55.4 KB, 78 views)
baswesterbaan is offline   Reply With Quote