View Single Post
Old 05-01-03, 01:17 PM   #65
suexec
Registered User
 
Join Date: Apr 2003
Posts: 54
Default

2.4.21-rc1's ACPI is from 2001. I had patched to the 20030328 release and the IO-APIC is detected. What is broken is the PCI IRQ routing for IRQ's higher than 16. 1-15 are fine. Giving the option pci=noacpi gets the new ACPI to work fine, but it's goes back to having just 15 interrupts, so it's back to the XT-PIC. I haven't tried the 2003042x release. I believe 2.4.21-rc1-ac2 (and ac3) have the latest ACPI patch, but I've not tried this either.
suexec is offline   Reply With Quote