View Single Post
Old 01-22-07, 09:10 PM   #1
bbmd
Registered User
 
Join Date: Jun 2006
Posts: 4
Default can't load the module

I have problem when i install NVIDIA-Linux-x86-1.0-9746 on debian/testing . It seems that i have compiled the module ,but can not load the module . I already have 1.0-9631 installed in my system.Here is the log:

.........
........
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most
frequently when this kernel module was built against the wrong or
improperly configured kernel sources, with a version of gcc that differs
from the one used to build the target kernel, or if a driver such as
rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
obtaining ownership of the NVIDIA graphics device(s).

Please see the log entries 'Kernel module load error' and 'Kernel
messages' at the end of the file '/var/log/nvidia-installer.log' for
more information.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
-1 No such device
-> Kernel messages:
NET: Registered protocol family 24
ip_tables: (C) 2000-2006 Netfilter Core Team
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 169
NVRM: loading NVIDIA Linux x86 Kernel Module 1.0-9631 Thu Nov 9 17:38:10
PST 2006
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
NVRM: The NVIDIA GeForce4 MX 440 with AGP8X GPU installed in this system is
NVRM: supported through the NVIDIA 1.0-96xx Legacy drivers. Please
NVRM: visit http://www.nvidia.com/object/unix.html for more
NVRM: information. The 1.0-9746 NVIDIA driver will ignore
NVRM: this GPU. Continuing probe...
NVRM: No NVIDIA graphics adapter found!
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 169
NVRM: loading NVIDIA Linux x86 Kernel Module 1.0-9631 Thu Nov 9 17:38:10
PST 2006
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
NVRM: The NVIDIA GeForce4 MX 440 with AGP8X GPU installed in this system is
NVRM: supported through the NVIDIA 1.0-96xx Legacy drivers. Please
NVRM: visit http://www.nvidia.com/object/unix.html for more
NVRM: information. The 1.0-9746 NVIDIA driver will ignore
NVRM: this GPU. Continuing probe...
NVRM: No NVIDIA graphics adapter found!
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
bbmd is offline   Reply With Quote