View Single Post
Old 05-03-03, 05:51 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

They're disabled by default because they cause stability problems on some systems.

That said, I don't have any problems when I turn them both on, but YMMV.

First, make sure that both your video card and motherboard chipset are reporting that they support both fast writes and SBA -- do this by looking in the other files in /proc/driver/nvidia/agp -- that is, host-bridge and card.

If they do, then set your distro up to pass a pair of options to the "nvidia" kernel module. If your nvidia module is getting loaded by modules.conf, then you can add a line reading options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1 to that file, run /sbin/depmod -a as root, and then unload and reload (from memory -- don't delete it off your system ) the kernel module.

If your distro uses an rc.modules file that calls /sbin/modprobe on a bunch of modules, then just add the NVreg_* stuff after the nvidia modprobe command (on the same line).

If your distro uses something like /etc/modules, which is just a list of modules to load at boot time, then I think you can add the options right after "nvidia" (again, on the same line) in that file, but I don't know for sure.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote