View Single Post
Old 01-29-07, 10:11 AM   #8
nyback
Registered User
 
Join Date: Apr 2004
Posts: 2
Default Re: Asus A8N-SLI NForce4 sound problem

Update if someone reads this thread....

I seems nowadays you dont need to lock the rate to 48 khz. But you still need to select PCM and set the volumes in the mixer as stated above.
I finaly took the time to check why i only got it to work with oss and not alsa in the arts settings.
If i select alsa and add "plug:dmix" to override selected device it works.
So how make dmix default in alsa?
My /etc/asound.conf :

pcm.nforce-hw {
type hw
card 0
device 2
}

pcm.!default {
type plug
slave.pcm "dmix"
}

pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "nforce-hw"
period_time 0
period_size 1024
buffer_size 32768
# rate 44100
}
bindings {
0 0
1 1
}
}

ctl.nforce {
type hw
card 0
device 2
}

ctl.nforce-hw {
type hw
card 0
device 2
}



I dont know if all is needed. I think only

pcm.!default {
type plug
slave.pcm "dmix"
}

is the important stuff. This makes dmix turned on for default device playback. Now i can select ALSA in all applications and i get SPDIF sound. I can also set arts to use plain ALSA and it works perfect. No extra settings needed in the arts config.



Quote:
Originally Posted by nyback
I had the same problem. Optical spdif on ASUS A8N-SLI Deluxe.
The information from fpikus together with last post in
https://bugtrack.alsa-project.org/al...ew.php?id=1083
And i got it to work.
Some clues if you use kde like me:
Get visible light on the optical. Then at least the output is active.
You should see the IEC958 Playback AC97-SPSA slider in kmix. Set it to "All the way down"=0=Off (If you turn the volume up on the slider the sound turns off !?!) Its the same thing as fpikus says about value=0 in asound.state)
In the third TAB in kmix (I dont know the name in english, i have swedish KDE, maybe "Switches") you should see a selector for IEC958, set it to PCM.
Only 48 khz works. So
mplayer -ao alsa:device=hw=0,2 -srate 48000 <file>
worked.
Set arts to use OSS and lock it on 48 khz.
SOUND!!!!
/Andreas
nyback is offline   Reply With Quote