View Single Post
Old 01-31-07, 04:18 PM   #1
breakerfall
Registered User
 
Join Date: Jan 2007
Posts: 3
Default Twinview, nvidia-settings and headaches.

Hi

I've been trying to get twinview to work how I want for a couple of days now, I keep coming close, but I'm not quite there.

I can get twinview to display across both of my screens, just the way I want, when starting x with both displays connected (I'm running on a laptop, with the DFP and an external TFT connected through the VGA port).

What I can't do, is boot up the laptop, startx and THEN connect a screen and use nvidia settings to setup dual screen on the fly. Well, I can enable dual screen, but then windows, dialogs, desktop panels etc, are stretched across both displays. This doesn't happen when I start X with both displays connected though.

So, questions:

1) Is it possible to enable dual screens on the fly, using nvidia-settings, but NOT have windows and widgets stretched across both displays?

2) When the seconday display device has a larger resolution than my primary display, there's obviously a large black void that I can't see, but it exists and unfortunately my mouse pointer can go into it. Is there a way to disable this from happening, without using panning? i.e. I want my screen resolution to be fixed, I want the mouse pointer bound by the resolution so that it can't go past the edge of the screen. Possible?

3) Minor issue... When I start X with both displays and both screens load up correctly - my fonts are slightly smaller than they usually are. This is a strange behaviour. Why would this be happening? Any ideas? Perhaps something to do with DPI? How would I set the config to keep my DPI / fonts at the right size for my primary display?

Here is a screenshot of the font / object size differences:

Before on the left, after on the right


Thanks for taking the time to read my mini-novel. =]


[edit]
The DPI issue has been fixed, using the option:

Code:
Option      "UseEDIDDpi" "DFP-0"
This sets the entire twinview screen to the DPI normally detected and used by the primary display (in my case the laptop screen). You can disable this option altogether and manually enter a DPI if you wish.

I still need to find a fix for my other problems. Anyone? Please?

Last edited by breakerfall; 01-31-07 at 06:22 PM.
breakerfall is offline   Reply With Quote