View Single Post
Old 05-05-03, 12:17 PM   #3
zorro
Registered User
 
Join Date: May 2003
Posts: 1
Default

Have you checked the ports?

look under /usr/ports/x11/nvidia-driver

There are two defines in the makefile that you wana check out, WITH_FREEBSD_AGP and WITHOUT_LINUX.

I didn't get the agp stuff in nvidia's driver to work so i had to use WITH_FREEBSD_AGP=yes, so i can recommend you to use that define. I'm also not intrested in linux stuff so i also used the other define (WITHOUT_LINUX=yes).

Note(!!): Even if you define WITHOUT_LINUX you will have dependency to linux.ko. To get rid of that you'll need to edit nv-freebsd.h and remove the line: "#define NV_SUPPORT_LINUX_COMPAT 1".

This is how i did it:
cd /usr/ports/x11/nvidia-driver
make WITHOUT_LINUX=yes WITH_FREEBSD_AGP=yes patch

*** edit nv-freebsd.h as described above ***

make WITHOUT_LINUX=yes WITH_FREEBSD_AGP=yes install

prompt# uname -a && sysctl -a | grep nvidia
FreeBSD volvo.tomten.homelinux.net 5.0-CURRENT FreeBSD 5.0-CURRENT #0: Sat May 3 18:28:28 CEST 2003 marcus@volvo.tomten.homelinux.net:/usr/obj/usr/src/sys/KERNEL17 i386

hw.nvidia.agp.card.rates: 4x 2x 1x
hw.nvidia.agp.card.fw: supported
hw.nvidia.agp.card.sba: not supported
hw.nvidia.agp.card.registers: 0x1f000017:0x1f000114
hw.nvidia.agp.status.status: enabled
hw.nvidia.agp.status.driver: freebsd (agp.ko)
hw.nvidia.agp.status.rate: 4x
hw.nvidia.agp.status.fw: enabled
hw.nvidia.agp.status.sba: disabled
hw.nvidia.version: NVIDIA FreeBSD x86 nvidia.ko Kernel Module 1.0-3203 Wed Oct 30 06:06:58 PST 2002
hw.nvidia.registry.EnableAGPSBA: 0
hw.nvidia.registry.EnableAGPFW: 1
hw.nvidia.registry.SoftEDIDs: 1
hw.nvidia.registry.Mobile: 4294967295
hw.nvidia.cards.0.model: GeForce4 MX 460
hw.nvidia.cards.0.irq: 11
hw.nvidia.cards.0.vbios: 04.17.00.58.12
hw.nvidia.cards.0.type: AGP
zorro is offline   Reply With Quote