View Single Post
Old 02-03-07, 09:43 PM   #4
tajin
Registered User
 
Join Date: Feb 2007
Posts: 6
Default Re: linux: Problems when compiling kernel module, Driver 1.0-7184 Legacy, Kernel 2.6.

Seems like I did something wrong when I update to Nvidia after installing FC6,
I was having problems to update kmod-nvidia using livna, this is what my computer reported, like mixing kernel i586 with headers i386( my CPU is PIV)

kernel-2.6.18-1.2798.fc6.i586
kernel-headers-2.6.18-1.2798.fc6.i386

So I follow the instructions here, under common issues, at: http://fedoraproject.org/wiki/Bugs/FC6Common

and after that upgrade this is what I got
[tajin@localhost ~]$ rpm -qa --queryformat "%{NA****-%{VERSION}-%{RELEASE}.%{ARC H}\n"|grep kernel|sort
kernel-2.6.18-1.2798.fc6.i586
kernel-2.6.19-1.2895.fc6.i686
kernel-headers-2.6.18-1.2798.fc6.i386

I follow the instructions for nvidia install, but I got the following fatal error so I remove it

FATAL: Error inserting nvidia (/lib/modules/2.6.19-1.2895.fc6/extra/nvidia/nvidia.ko): No such device

I removed both packages and install with yum as follows as per one thread I found at Fedora News org
# yum install kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx
My output was:
Running Transaction
Installing: kmod-nvidia-96xx ######################### [1/2]
Installing: xorg-x11-drv-nvidia-96xx ######################### [2/2]

Installed: kmod-nvidia-96xx.i686 0:1.0.9631-4.2.6.19_1.2895.fc6 xorg-x11-drv-nvidia-96xx.i386 0:1.0.9631-5.lvn6
Complete!

But now I don't have access to change refreshing rate for my 17" Hansol 720Ed monitor after I installed nvidia on FC6, this is my /etc/X11/xorg.conf, the only choices for refreshing rate now is 50~56 Hz, monitor data is:

Hansol 17"
1280X1024 -60Hz NI
1024x768 -75Hz NI
HorizSync 30~75Hz
VertRefressh 47~160Hz


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
ModelName "Monitor 1024x768"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

How do I change /etc/X11/xorg.conf to get a refreshing rate of 75Hz?, Do I need both monitor and screen sections?

and this is nvidia settings

[tajin@localhost ~]$ nvidia-settings -q RefreshRate

Attribute 'RefreshRate' (localhost.localdomain:0.0; display device: CRT-0):
85.00 Hz.
'RefreshRate' is an integer attribute.
'RefreshRate' is a read-only attribute.
'RefreshRate' is display device specific.
'RefreshRate' can use the following target types: X Screen, GPU.

What's display device: CRT-0 on nvidia settings?, seems like I shoud install legacy for nvidia (and not kmod-nvidia-96xx and xorg-x11-drv-nvidia-96xx) as you did?, do you any way to correct my problem?
tajin is offline   Reply With Quote