View Single Post
Old 02-07-07, 12:05 PM   #18
Nebulus
Registered User
 
Join Date: Jan 2005
Posts: 23
Default Re: 6600GT Terrible 2D performance

You can solve slow 2D Font Redering under KDE, by disable the antialiased Fonts completly (in KDE Control Center).

And instead install a patched freetype-2.2.1, with patented font Rendering enabled. (It is disabled by default) You must recompile freetype-2.2.1 from Source.


Here is a little Hint, how to do this:

DOWNLOAD:
http://download.savannah.gnu.org/rel...-2.2.1.tar.bz2

PATCH:
Enable Patented Font Rendering with patchfile freetype-2.2.1_patented_fonts.patch.txt
tar xvfj freetype-2.2.1.tar.bz2
patch -p0 < freetype-2.2.1_patented_fonts.patch

COMPILE:
./configure --prefix=/usr &&
make &&
make install

Make shure your /usr/lib/libfreetype.so.6.3.10 has been updated !
Restart X11.

Thats all, if you now install the copyrighted microsoft ttf fonts on your linux system, you have good looking fonts, without antialiased switched on. And the Best, it looks a loot better than before.
Nebulus is offline   Reply With Quote