View Single Post
Old 02-07-07, 04:31 PM   #1
ahamilton9
Registered User
 
Join Date: Feb 2007
Posts: 2
Default Kmod-Nvidia won't install, don't understand

I have the Livna Repo tacked on to yum, i have all my packages updated and followed the instructions here: http://www.nvnews.net/vbulletin/showthread.php?t=72490 After all this, I get an install dependancies list, I accept and get errors. I tried installing kernel.i686, which said it was an older version and did nothing, and kernel-2.6.19-1.2895.fc6.i686 which just says nothing to do... heres the exact screen im getting from the time I lauch the command from root.

Quote:
[root@localhost Andrew]# yum install kmod-nvidia
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 1.8 MB 00:02
extras : ################################################## 5891/5891
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kmod-nvidia.i686 0:1.0.9746-1.2.6.19_1.2895.fc6 set to be installed
--> Running transaction check
--> Processing Dependency: kernel-i686 = 2.6.19-1.2895.fc6 for package: kmod-nvidia
--> Processing Dependency: nvidia-kmod-common >= 1.0.9746 for package: kmod-nvidia
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xorg-x11-drv-nvidia.i386 0:1.0.9746-7.lvn6 set to be updated
---> Package kernel.i686 0:2.6.19-1.2895.fc6 set to be installed
--> Running transaction check
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i586 0:2.6.18-1.2798.fc6 set to be erased
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
kmod-nvidia i686 1.0.9746-1.2.6.19_1.2895.fc6 livna 2.3 M
Removing:
kernel i586 2.6.18-1.2798.fc6 installed 43 M
Installing for dependencies:
kernel i686 2.6.19-1.2895.fc6 updates 16 M
xorg-x11-drv-nvidia i386 1.0.9746-7.lvn6 livna 4.9 M

Transaction Summary
================================================== ===========================
Install 3 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Total download size: 24 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error: package kernel-2.6.19-1.2895.fc6 is already installed
file /boot/System.map-2.6.19-1.2895.fc6 from install of kernel-2.6.19-1.2895.fc6 conflicts with file from package kernel-2.6.19-1.2895.fc6
file /boot/config-2.6.19-1.2895.fc6 from install of kernel-2.6.19-1.2895.fc6 conflicts with file from package kernel-2.6.19-1.2895.fc6
file /boot/symvers-2.6.19-1.2895.fc6.gz from install of kernel-2.6.19-1.2895.fc6 conflicts with file from package kernel-2.6.19-1.2895.fc6
file /boot/vmlinuz-2.6.19-1.2895.fc6 from install of kernel-2.6.19-1.2895.fc6 conflicts with file from package kernel-2.6.19-1.2895.fc6

[root@localhost Andrew]#
Any help would be appreciated, I'll give more info if requested, just ask.
ahamilton9 is offline   Reply With Quote