View Single Post
Old 02-12-07, 12:48 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Problems with 2.6.20 and SLI

This looks like a PCI bus /proc/mtrr problem (potentially specific to your hardware). If you look at the bug report you attached you'll see the the memory ranges that are defined for each of the two cards are different. One has 256MB, while the other is getting 1GB (which looks wrong):

02:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GT] (rev a1) (prog-if 00 [VGA])
Subsystem: ASUSTeK Computer Inc. Unknown device 81f7
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
Memory at 80000000 (64-bit, prefetchable) [size=1024M]
Memory at fb000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at 9c00 [size=128]
[virtual] Expansion ROM at fcfe0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint IRQ 0


07:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GT] (rev a1) (prog-if 00 [VGA])
Subsystem: ASUSTeK Computer Inc. Unknown device 81f7
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at f7000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f8000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at 7c00 [disabled] [size=128]
[virtual] Expansion ROM at f9000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint IRQ 0

This isn't an nvidia driver bug, its an issue somewhere in the kernel and/or BIOS of the motherboard you're using.

Thanks,
Lonni
netllama is offline   Reply With Quote