View Single Post
Old 02-12-07, 12:48 PM   #1
BruderB
Registered User
 
Join Date: Feb 2007
Posts: 2
Default Geforce4 440 Go in Toshiba Laptop with Debian Etch

Hej all,

I'm new to this forum and I can say I'm very hopeful to find help in here! I already spent some days in trying and reading....

I want to use a NVIDIA-driven X-server on my Toshiba Laptop Satellite 1900-704 with 1280x1024x24. I use Debian Linux testing (etch) with Kernel 2.6.18.

The NVIDIA-card ist recognized by lspci:
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 440 Go] (rev a3)

The X-Server runs with driver 'nv' and 1280x1024x24.

I got the driver NVIDIA-Linux-x86-1.0-9631-pkg1.run and compiled it. I let the automatic xconfig utility update my /etc/X11/xorg.conf.

After rebooting, screen turns black and that's it. It turns deep black, like switched off.

The driver is present:
nl-lt-boris:~# lsmod | grep nvidia
nvidia 4712532 22
i2c_core 19680 6 nvidia,dvb_usb_dibusb_mb,dvb_usb,dvb_pll,dib3000_c ommon,i2c_i801
agpgart 29896 2 nvidia,intel_agp

I tried A LOT of things from here but with no success. I found additional information on
http://us.download.nvidia.com/XFree8...ppendix-i.html
and did
nl-lt-boris:~# rmmod nvidia
nl-lt-boris:~# modprobe nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=2
nl-lt-boris:~# /etc/init.d/gdm start

That brings the most success: The screen wents back from OFF to deep dark backlighted and brings half-screen-sized white areas randomly alternating with every second....

Does anybody have a good suggestion???

Boris
BruderB is offline   Reply With Quote