View Single Post
Old 02-20-07, 06:53 AM   #1
boppen
Registered User
 
Join Date: Oct 2005
Posts: 8
Default XvMC freezes my MythTV-system

Hi!

I have been playing with XvMC a little to reduce CPU usage when wathing HDTV with MythTV, but I have got a problem. when I'm using XvMC my system freezes now and then, I have to push the reset button to restart it.

I'm using driver 9746 and Linux kernel 2.6.18 (-gentoo-r6). My graphics is a integrated 6150 on a ASUS A8N-VM CSM.

This is the last output from Myth when the system freeze:
Code:
2007-02-20 12:24:46.570 XMLParse::LoadTheme using /usr/local/share/mythtv/themes/Retro/ui.xml
2007-02-20 12:24:46.638 Video timing method: RTC
[mpegts @ 0x2b575e8f2480]Parser not found for Codec Id: 94211 !
2007-02-20 12:24:48.130 VideoOutputXv: XvMCTex: Init failed
2007-02-20 12:24:48.131 VideoOutputXv: XvMC Adaptor Name: 'NV17 Video Texture'
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  141
  Minor opcode:  14
  Resource id:  0x1a8
2007-02-20 12:24:48.449 VideoOutputXv: ProcessFrameXvMC: Tried to reuse frame but failed
2007-02-20 12:24:48.449 VideoOutputXv: ProcessFrameXvMC: Called without frame
2007-02-20 12:24:48.450 AFD: Opened codec 0x2a63e50, id(MPEG2VIDEO_XVMC) type(Video)
2007-02-20 12:24:48.450 AFD: Opened codec 0x1282cf0, id(MP3) type(Audio)
2007-02-20 12:24:48.653 Opening OSS audio device '/dev/dsp'.
2007-02-20 12:24:48.657 NVP: Enabling Audio
2007-02-20 12:24:48.658 VideoOutputXv: ProcessFrameXvMC: Tried to reuse frame but failed
2007-02-20 12:24:48.658 VideoOutputXv: ProcessFrameXvMC: Called without frame
XvMC: picture structure FRAME
2007-02-20 12:24:50.350 NVP: prebuffering pause
And this is a 'top' in the same second as the system freezes (yes, I'm running Myth as root ;-)


Thans for any help!

Last edited by boppen; 02-21-07 at 02:54 PM.
boppen is offline   Reply With Quote