View Single Post
Old 02-20-07, 11:39 AM   #1
Big P
Registered User
 
Join Date: Dec 2004
Posts: 180
Default Monitor Refresh Rate

Hi,

I own a 21" CRT monitor, a Dell Trinitron, and I was using nvidia-settings to set the refresh rate (hz) and resolution. Afaik, my monitor was running at 1600x1200@75hz as I thought until today when I tested out xrandr.

It gives the following (relevant) output:
Code:
 SZ:    Pixels          Physical       Refresh
*0   1600 x 1200   ( 383mm x 290mm )  *50   51   57   58   59  
 1   1280 x 1024   ( 306mm x 247mm )   52   63   64  
 2   1152 x 864    ( 276mm x 209mm )   53  
 3   1024 x 768    ( 245mm x 185mm )   54   68   69   70   71   72  
 4    800 x 600    ( 191mm x 145mm )   55   78   79   80   81   82   83   84   85   86   87
As you can see, X is actually running at 50hz, and the available refresh rates are unusual. In windows this same monitor runs at 1600x1200@85hz (at least according to nvidia drivers).

The nvidia drivers in both windows and linux see the monitor as "DELL D1626H", and the following are the relevant sections of my xorg.conf (which i got from nvidia-settings "Save to X configuration file" option.

Code:
Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL D1626HT"
    HorizSync       30.0 - 107.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 6600 GT"

        Option "CursorShadow"  "on" 
        Option "RenderAccel" "true"
        Option "XAANoOffscreenPixmaps" "true"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        Option "AddARGBGLXVisuals" "True"
        Option "DisableGLXRootClipping" "True"

    Option         "metamodes" "1600x1200_75 +0+0; 1600x1200 +0+0; 1280x1024_75 
+0+0; 1152x864 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Any help on getting my refresh rate fixed would be greatly appreciated. If I can give any more info please let me know.

Regards,
Big P is offline   Reply With Quote