View Single Post
Old 02-20-07, 02:22 PM   #4
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: Mplayer NOT smooth on tv-out.

Quote:
Originally Posted by Darkvater
Perhaps unrelated but did you sync the refresh rate to your tv-out? My LCD is 60Hz the TV is 50Hz and if I don't set 'Sync to this display device' properly I get jerky playback on tv with tears and jumps.
Man you were right, it's nvidia-settings that doesn't work very well in loading settings, in fact if i open the gui and de/reselect all the voices it syncs fine...

But my ~/.nvidia-settings-rc is correct, i've:
Quote:
1/SyncToVBlank=1
1/XVideoTextureSyncToVBlank=1
1/XVideoBlitterSyncToVBlank=1
1/XVideoSyncToDisplay=256
And if i query them:
nvidia-settings -q all|grep -i Sync|grep Attribute
Quote:
Attribute 'SyncToVBlank' (klinux:0.0): 1.
Attribute 'XVideoTextureSyncToVBlank' (klinux:0.0): 1.
Attribute 'XVideoBlitterSyncToVBlank' (klinux:0.0): 1.
Attribute 'XVideoSyncToDisplay' (klinux:0.0): 0x00000001.
Attribute 'SyncToVBlank' (klinux:0.1): 1.
Attribute 'XVideoTextureSyncToVBlank' (klinux:0.1): 1.
Attribute 'XVideoBlitterSyncToVBlank' (klinux:0.1): 1.
Attribute 'XVideoSyncToDisplay' (klinux:0.1): 0x00000100.
...which should be correct too, but something has no effect on TV-0 (:0.1)

So i added:
Quote:
nvidia-settings -a :0.1/XVideoSyncToDisplay=256
nvidia-settings -a :0.1/XVideoTextureSyncToVBlank=1
nvidia-settings -a :0.1/XVideoBlitterSyncToVBlank=1
to my ~/.kde/Autostart/nvidia.sh
...And now everything 'seems' to work

Hope this will help someone.
kokoko3k is offline   Reply With Quote