View Single Post
Old 02-20-07, 01:30 PM   #1
gougou
Registered User
 
Join Date: Feb 2007
Posts: 1
Question wrong resolution detected

Hi,

I have a 7600 GS PCIe card running under ubuntu edgy with linux drivers
"NVIDIA-Linux-x86-1.0-9746". My display is an Optoma HD72 that is able
to do 1280x768 natively and 1920x1080 compressed.

This is my xorg.conf config (relevant part):

Section "Screen"
Identifier "moultimedia"
Device "nvidia7600"
Monitor "optomahd72"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x768"
EndSubSection
EndSection

The driver is detecting the HD72 but the max resolution is 1280x720
instead of the native 1280x768 or more. Resolution is ok with the latest
drivers in windows xp.

Any special config I can put in my config file to force a specific
resolution? I tried "UseEdidDpi" "FALSE" and "UseEDID" "FALSE" and it
fails. The latest one gives me a 640x480 window.

Note: get-edid is failing:

# get-edid
get-edid: get-edid version 1.4.1

Performing real mode VBE call
Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
Function supported
Call successful

VBE version 300
VBE string at 0x11110 "NVIDIA"

VBE/DDC service about to be called
Report DDC capabilities

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
Function supported
Call successful

Monitor and video card combination does not support DDC1 transfers
Monitor and video card combination supports DDC2 transfers
0 seconds per 128 byte EDID block transfer
Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
Read EDID

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
Function supported
Call failed

The EDID data should not be trusted as the VBE call failed

[snip junk dump]

Thanks guys and keep the good work,

Gabriel
gougou is offline   Reply With Quote