View Single Post
Old 02-26-07, 09:28 PM   #2
dougmc
Registered User
 
Join Date: Apr 2006
Location: Austin, TX
Posts: 4
Send a message via AIM to dougmc
Default Re: x86_64-1.0-9746 freezes OpenSuse 10.2

I've got a similar problem, but using Fedora Core 5. I've tried several versions of the NVIDIA driver, but it doesn't matter. If I use a 2.6.17 kernel, things work -- but as soon as I go to a 2.6.18 kernel, things break.

I can reproduce it at will -- boot a 2.6.18 kernel, reinstall the driver, then let X start -- it crashes. boot a 2.6.17 kernel, reinstall the driver, let X start -- it works.

As soon as X starts, the computer locks up. Loading the module doesn't do it -- it's X starting that does it.

I also have a GeForce 6200 card --

(--) PCI:*(1:0:0) nVidia Corporation GeForce 6200 rev 161, Mem @ 0xf2000000/24, 0xe0000000/28, 0xf3000000/24
(II) NVIDIA(0): NVIDIA GPU GeForce 6200 at PCI:1:0:0 (GPU-0)

and my motherboard is an Nforce 3 model, running an Athlon X2 3800 chip, running x86-64. I guess I should do try again to track it down, and file a proper problem report, since it looks like it's not just me.

One thing that doesn't make much sense with your post --

FATAL: Error inserting nvidia (/lib/modules/2.6.18.2-34-default/kernel/drivers/video/nvidia.ko): Invalid module format

if the module can't be loaded, I wouldn't expect that to crash the system -- it should just keep X from starting. (on my system, the module starts up fine.)
dougmc is offline   Reply With Quote