View Single Post
Old 03-07-07, 10:47 PM   #13
basso
Registered User
 
Join Date: Mar 2007
Posts: 2
Default Re: Unable to load the kernel module 'nvidia.ko'

Hello folks,

I've read all the posts in this thread and still cannot find anything related to my problem...

I've installed Fedora Core 6 on a pc with an nVidia GEForce 5200 and I can't seem to install the driver.

I launched the installation and it said that it needs to recompile my kernel since there's no precompiled kernel found.

After that I get an error message saying that the compile was not successful and that I should check the "nvidia-installer.log" file.

The file reads the following:

Code:
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most
       frequently when this kernel module was built against the wrong or
       improperly configured kernel sources, with a version of gcc that differs
       from the one used to build the target kernel, or if a driver such as
       rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
       obtaining ownership of the NVIDIA graphics device(s).
       
       Please see the log entries 'Kernel module load error' and 'Kernel
       messages' at the end of the file '/var/log/nvidia-installer.log' for
       more information.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
   -1 No such device
-> Kernel messages:
   Bluetooth: HCI device and connection manager initialized
   Bluetooth: HCI socket layer initialized
   Bluetooth: L2CAP ver 2.8
   Bluetooth: L2CAP socket layer initialized
   Bluetooth: RFCOMM socket layer initialized
   Bluetooth: RFCOMM TTY layer initialized
   Bluetooth: RFCOMM ver 1.8
   Bluetooth: HIDP (Human Interface Emulation) ver 1.1
   SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
   SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
   eth0: no IPv6 routers present
   hda: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
   hda: drive_cmd: error=0x04 { DriveStatusError }
   ide: failed opcode was: 0xb0
   hdb: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
   hdb: drive_cmd: error=0x04 { DriveStatusError }
   ide: failed opcode was: 0xb0
   nvidia: module license 'NVIDIA' taints kernel.
   ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 217
   NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
   NVRM: BAR1 is 0M @ 0x00000000 (PCI:0000:00.1)
   NVRM: The system BIOS may have misconfigured your graphics card.
   nvidia: probe of 0000:01:00.0 failed with error -1
   NVRM: The NVIDIA probe routine failed for 1 device(s).
   NVRM: None of the NVIDIA graphics adapters were initialized!
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.
I tried to check for the file ./usr/src/nv/nvidia.ko and found that the directory /nv does not exist at all!

I'm no expert in linux, in fact this is my first installation of the OS, any help?

Thanks in advace
basso is offline   Reply With Quote