View Single Post
Old 03-08-07, 08:49 AM   #2
Dubious Dave
Registered User
 
Join Date: Mar 2007
Location: Syracuse, NY, USA
Posts: 6
Default Re: Got GeForce FX5500 to work with Win98!

Okay so here's how to do it in win98 without hacking the registry. This handles the problem of nvidia refusing to work with your monitor because it doesn't support EDID probing. This should also straighten up Monitor/Display(video adapter) associations that have gone bad. Warning this may screw up your entire system, but I did this on two different systems with similar problems.

1) Uninstall all previous nvidia/ati drivers.
2) Use driver cleaner to clean up the remainder in registry and in file system.
3) Open up device manager and delete all Displays and all monitors.
4) Reboot. You might have to reboot 2 or 3 times in a row. This forces win98 to rebuild a clean default Display and default Monitor association. If win98 asks to install standard VGA Display, agree and let it look on your hard driver for the driver.
5) If it finds your monitor and installs it instead of a default monitor that's okay. If it doesn't find your monitor, install it with the OEM disk.
6) At this point you should have a single Standard VGA Display and single Monitor in Device Manager. Right click on the desktop and access the display properties. On the settings tab click advanced. On the monitor tab clear the check box for autodetect plug-n-play monitor. Apply and exit.
7) Install the nvidia driver and reboot.
8) At this point it may work fine and everything is awesome. However, if your resolution is poor, check your desktop properties. Right click on the desktop and access the display properties. On the settings tab look to see what monitor is associated with your new driver. If it says default monitor, then click advanced. On the monitor tab click the "change" button and select your monitor or "reinstall" with your OEM disc. Apply, exit, and reboot.
9) If you're still having problems you're hosed.
Dubious Dave is offline   Reply With Quote